sqlite: add json1 support
authorBradford Barr <bradford@density.io>
Mon, 26 Jun 2017 16:17:44 +0000 (09:17 -0700)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 2 Jul 2017 21:59:08 +0000 (23:59 +0200)
Add support for the JSON1 SQLite extensions. This extension allows SQLite to
store and query JSON objects in a database.

Signed-off-by: Bradford Barr <bradford@density.io>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/sqlite/Config.in
package/sqlite/sqlite.mk

index c9fde53b3650206e18d717a8eabfa5c17c9cc7f5..eec41c5332a90bb7bb7e05a9c3c10e6d8811d277 100644 (file)
@@ -22,6 +22,12 @@ config BR2_PACKAGE_SQLITE_ENABLE_FTS3
          (see http://www.sqlite.org/amalgamation.html), version 3 of
          the full-text search engine is added to the build automatically.
 
+config BR2_PACKAGE_SQLITE_ENABLE_JSON1
+       bool "Enable the JSON extensions for SQLite"
+       help
+         When this option is defined in the amalgamation, the JSON
+         extensions are added to the build automatically.
+
 config BR2_PACKAGE_SQLITE_ENABLE_UNLOCK_NOTIFY
        bool "Enable sqlite3_unlock_notify() interface"
        help
index 7b9c897f6b549346e12c3a65cfa52bfe245efba3..f6b249d94166f2e3adc8fad38826cfe8966aeeba 100644 (file)
@@ -19,6 +19,10 @@ ifeq ($(BR2_PACKAGE_SQLITE_ENABLE_FTS3),y)
 SQLITE_CFLAGS += -DSQLITE_ENABLE_FTS3
 endif
 
+ifeq ($(BR2_PACKAGE_SQLITE_ENABLE_JSON1),y)
+SQLITE_CFLAGS += -DSQLITE_ENABLE_JSON1
+endif
+
 ifeq ($(BR2_PACKAGE_SQLITE_ENABLE_UNLOCK_NOTIFY),y)
 SQLITE_CFLAGS += -DSQLITE_ENABLE_UNLOCK_NOTIFY
 endif