projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
8b19d4d
)
package/zxing-cpp: add opencv3 optional dependency
author
Fabrice Fontaine
<fontaine.fabrice@gmail.com>
Fri, 16 Oct 2020 21:45:51 +0000
(23:45 +0200)
committer
Yann E. MORIN
<yann.morin.1998@free.fr>
Sat, 17 Oct 2020 12:14:00 +0000
(14:14 +0200)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[yann.morin.1998@free.fr: split to a separate condition]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/zxing-cpp/zxing-cpp.mk
patch
|
blob
|
history
diff --git
a/package/zxing-cpp/zxing-cpp.mk
b/package/zxing-cpp/zxing-cpp.mk
index c138c925bb012dc59613ee899bf82e5a0034c204..fbe3cc7dd92f1ce465dc1e2b34f6d0fa837c3d81 100644
(file)
--- a/
package/zxing-cpp/zxing-cpp.mk
+++ b/
package/zxing-cpp/zxing-cpp.mk
@@
-19,6
+19,9
@@
endif
ifeq ($(BR2_PACKAGE_OPENCV_LIB_HIGHGUI),y)
ZXING_CPP_DEPENDENCIES += opencv
ZXING_CPP_CONF_OPTS += -DBUILD_OPENCV=ON
+else ifeq ($(BR2_PACKAGE_OPENCV3_LIB_HIGHGUI),y)
+ZXING_CPP_DEPENDENCIES += opencv3
+ZXING_CPP_CONF_OPTS += -DBUILD_OPENCV=ON
else
ZXING_CPP_CONF_OPTS += -DBUILD_OPENCV=OFF
endif