uclibc: copy config file from configure iso patch step
authorThomas De Schampheleire <patrickdepinguin@gmail.com>
Thu, 13 Feb 2014 11:34:45 +0000 (12:34 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 14 Feb 2014 20:36:51 +0000 (21:36 +0100)
The three typical packages that use .config files in buildroot copy the
config file at different times in the build process:

    busybox copies its .config from the post-extract hook.
    linux copies its .config in the configure_cmds.
    uclibc copies its .config from the post-patch hook.

Copying the .config file from the configure step is the only way to properly
support an OVERRIDE_SRCDIR that does not yet have the .config file, because
the extract and patch steps are skipped in that case.

In a previous patch, the situation was already fixed for busybox. This patch
applies the same fix to uclibc: copy the config file from the configure
step, as linux is doing.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/uclibc/uclibc.mk

index 7df9721c3512b5f6ea179e87ce1cc1c3f1e8ad73..8497b46971026883ceb7ab30a0fed4781bc27c17 100644 (file)
@@ -453,9 +453,8 @@ define UCLIBC_SETUP_DOT_CONFIG
                oldconfig
 endef
 
-UCLIBC_POST_PATCH_HOOKS += UCLIBC_SETUP_DOT_CONFIG
-
 define UCLIBC_CONFIGURE_CMDS
+       $(UCLIBC_SETUP_DOT_CONFIG)
        $(MAKE1) -C $(UCLIBC_DIR) \
                $(UCLIBC_MAKE_FLAGS) \
                PREFIX=$(STAGING_DIR) \