libsepol: bump version to 2.6
authorAdam Duskett <Aduskett@gmail.com>
Mon, 9 Jan 2017 16:15:22 +0000 (11:15 -0500)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 25 Jan 2017 10:25:26 +0000 (23:25 +1300)
Also removed patch 0003-add-stdarg-include.patch as this has been
committed to upstream.

Signed-off-by: Adam Duskett <aduskett@codeblue.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libsepol/0003-add-stdarg-include.patch [deleted file]
package/libsepol/0003-revert-ln-relative.patch [new file with mode: 0644]
package/libsepol/0004-revert-ln-relative.patch [deleted file]
package/libsepol/libsepol.hash
package/libsepol/libsepol.mk

diff --git a/package/libsepol/0003-add-stdarg-include.patch b/package/libsepol/0003-add-stdarg-include.patch
deleted file mode 100644 (file)
index 246c965..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-Add missing <stdarg.h> include
-
-This is needed to fix the build on uClibc, due to the usage of
-va_list.
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-Index: b/cil/src/cil_log.h
-===================================================================
---- a/cil/src/cil_log.h
-+++ b/cil/src/cil_log.h
-@@ -30,6 +30,7 @@
- #define CIL_LOG_H_
- #include <stdlib.h>
-+#include <stdarg.h>
- #include <cil/cil.h>
- #define MAX_LOG_SIZE 512
diff --git a/package/libsepol/0003-revert-ln-relative.patch b/package/libsepol/0003-revert-ln-relative.patch
new file mode 100644 (file)
index 0000000..0902d8d
--- /dev/null
@@ -0,0 +1,24 @@
+Makefile: revert libsepol: use ln --relative to create .so symlinks
+
+This reverts 71393a181d63c9baae5fe8dcaeb9411d1f253998
+
+ln --relative is too recent to be available in all distributions,
+especially enterprise-grade distros that can stick around as long as
+they are maintained (up to 10 years in some cases?).
+
+For the sake of Buildroot, revert the upstream patch.
+
+Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
+
+diff -durN a/src/Makefile b/src/Makefile
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -77,7 +77,7 @@
+ ifeq ($(STATIC),)
+       test -d $(SHLIBDIR) || install -m 755 -d $(SHLIBDIR)
+       install -m 755 $(LIBSO) $(SHLIBDIR)
+-      ln -sf --relative $(SHLIBDIR)/$(LIBSO) $(LIBDIR)/$(TARGET)
++      cd $(LIBDIR) && ln -sf ../../`basename $(SHLIBDIR)`/$(LIBSO) $(TARGET)
+ endif
+ relabel:
diff --git a/package/libsepol/0004-revert-ln-relative.patch b/package/libsepol/0004-revert-ln-relative.patch
deleted file mode 100644 (file)
index 0902d8d..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-Makefile: revert libsepol: use ln --relative to create .so symlinks
-
-This reverts 71393a181d63c9baae5fe8dcaeb9411d1f253998
-
-ln --relative is too recent to be available in all distributions,
-especially enterprise-grade distros that can stick around as long as
-they are maintained (up to 10 years in some cases?).
-
-For the sake of Buildroot, revert the upstream patch.
-
-Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
-
-diff -durN a/src/Makefile b/src/Makefile
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -77,7 +77,7 @@
- ifeq ($(STATIC),)
-       test -d $(SHLIBDIR) || install -m 755 -d $(SHLIBDIR)
-       install -m 755 $(LIBSO) $(SHLIBDIR)
--      ln -sf --relative $(SHLIBDIR)/$(LIBSO) $(LIBDIR)/$(TARGET)
-+      cd $(LIBDIR) && ln -sf ../../`basename $(SHLIBDIR)`/$(LIBSO) $(TARGET)
- endif
- relabel:
index 266ce43f73901b2b7689d9c57d4dad2c3d9e6db4..6c705067a22713a44856d84ea597236325203876 100644 (file)
@@ -1,2 +1,2 @@
 # From https://github.com/SELinuxProject/selinux/wiki/Releases
-sha256 2bdeec56d0a08b082b93b40703b4b3329cc5562152f7254d8f6ef6b56afe850a  libsepol-2.5.tar.gz
+sha256 d856d6506054f52abeaa3543ea2f2344595a3dc05d0d873ed7f724f7a16b1874  libsepol-2.6.tar.gz
index bf85eef37d6cf21a3f6b4cd4569f165f1c6065c0..61d1e611de1c247671f80261111f26954b3a9bfe 100644 (file)
@@ -4,8 +4,8 @@
 #
 ################################################################################
 
-LIBSEPOL_VERSION = 2.5
-LIBSEPOL_SITE = https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20160223
+LIBSEPOL_VERSION = 2.6
+LIBSEPOL_SITE = https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20161014
 LIBSEPOL_LICENSE = LGPLv2.1+
 LIBSEPOL_LICENSE_FILES = COPYING