package/tvheadend: Add optional dependency to libiconv
authorBernd Kuhls <bernd.kuhls@t-online.de>
Wed, 11 Jun 2014 13:02:06 +0000 (15:02 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 11 Jun 2014 13:18:20 +0000 (15:18 +0200)
To get reproducable builds depend on libiconv if needed.

tvheadend configure either shows

  checking for cc libiconv ...                      fail

or

  checking for cc libiconv ...                      ok

depending on the presence of libiconv, and gets linked

output/host/usr/bin/i586-buildroot-linux-uclibc-readelf -a output/target/usr/bin/tvheadend | grep NEEDED | grep iconv
 0x00000001 (NEEDED)                     Shared library: [libiconv.so.2]

Please note that libiconv is not a hard-dependency.

Tested with minimal defconfig

BR2_TOOLCHAIN_BUILDROOT_LARGEFILE=y
BR2_TOOLCHAIN_BUILDROOT_INET_IPV6=y
BR2_PACKAGE_LIBICONV=y
BR2_PACKAGE_TVHEADEND=y

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/tvheadend/tvheadend.mk

index c582c0704e02333ede3f1915f4049a91d71015a7..4d0a16d51dbad38f1f7e7335cf44e6eeb5c68ee0 100644 (file)
@@ -14,6 +14,10 @@ ifeq ($(BR2_PACKAGE_AVAHI),y)
 TVHEADEND_DEPENDENCIES += avahi
 endif
 
+ifeq ($(BR2_PACKAGE_LIBICONV),y)
+TVHEADEND_DEPENDENCIES += libiconv
+endif
+
 TVHEADEND_DEPENDENCIES += dtv-scan-tables
 
 define TVHEADEND_CONFIGURE_CMDS