exim: allow using a custom configuration file
authorLuca Ceresoli <luca@lucaceresoli.net>
Fri, 4 Jul 2014 15:56:24 +0000 (17:56 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 15 Jul 2014 19:29:13 +0000 (21:29 +0200)
exim has lots of options configurable before the build process. It's not
useful to have all of them exposed in Buildroot, yet users may need to tweak
them.

Allow the user to pass an entire configuration file to make exim totally
reconfigurable without bloating the Buildroot menus.

[Thomas: remove "for exim" from Config.in options prompts.]

Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/exim/Config.in
package/exim/exim.mk

index a71106b2bb842351dbb4d594a8f546978fd6dca4..af54acbbf2efd2707eac5c75a0742fbc81bf6ce0 100644 (file)
@@ -8,3 +8,28 @@ config BR2_PACKAGE_EXIM
          Cambridge for use on Unix systems connected to the Internet.
 
          http://www.exim.org/
+
+if BR2_PACKAGE_EXIM
+
+config BR2_PACKAGE_EXIM_CUSTOM_CONFIG
+       bool "Use a custom configuration file"
+       help
+         By default Buildroot generates configuration file for exim with
+         reasonable settings.
+         Enable this option if you want to override the configuration file
+         generated by Buildroot with a customized file. Then set the path
+         to your configuration file in BR2_PACKAGE_EXIM_CUSTOM_CONFIG_FILE.
+
+config BR2_PACKAGE_EXIM_CUSTOM_CONFIG_FILE
+       string "Custom configuration file"
+       depends on BR2_PACKAGE_EXIM_CUSTOM_CONFIG
+       help
+         Specify a file to use as the exim configuration file.
+
+         This file shall comply with the syntax defined in the exim
+         documentation (http://www.exim.org/docs.html).
+         Buildroot will generate a configuration file composed of the
+         content of the file you provide plus the toolchain-related
+         settings needed for cross-compilation.
+
+endif
index 0f9c6af78455f3836e98bc4b4c0153c691b13feb..2e51a0d9b96e75f54d386c4770c06a44d384a18b 100644 (file)
@@ -30,7 +30,12 @@ define exim-config-add # variable-name, variable-value
        echo "$1=$2" >>$(@D)/Local/Makefile
 endef
 
-define EXIM_CONFIGURE_CMDS
+define EXIM_USE_CUSTOM_CONFIG_FILE
+       $(INSTALL) -m 0644 $(BR2_PACKAGE_EXIM_CUSTOM_CONFIG_FILE) \
+               $(@D)/Local/Makefile
+endef
+
+define EXIM_USE_DEFAULT_CONFIG_FILE
        $(INSTALL) -m 0644 $(@D)/src/EDITME $(@D)/Local/Makefile
        $(call exim-config-change,BIN_DIRECTORY,/usr/sbin)
        $(call exim-config-change,CONFIGURE_FILE,/etc/exim/configure)
@@ -41,6 +46,9 @@ define EXIM_CONFIGURE_CMDS
        $(call exim-config-change,PCRE_CONFIG,no)
        $(call exim-config-change,HAVE_ICONV,no)
        $(call exim-config-unset,EXIM_MONITOR)
+endef
+
+define EXIM_CONFIGURE_TOOLCHAIN
        $(call exim-config-add,CC,$(TARGET_CC))
        $(call exim-config-add,CFLAGS,$(TARGET_CFLAGS))
        $(call exim-config-add,AR,$(TARGET_AR) cq)
@@ -49,6 +57,21 @@ define EXIM_CONFIGURE_CMDS
        $(call exim-config-add,HOSTCFLAGS,$(HOSTCFLAGS))
 endef
 
+ifeq ($(BR2_PACKAGE_EXIM_CUSTOM_CONFIG),y)
+ifeq ($(call qstrip,$(BR2_PACKAGE_EXIM_CUSTOM_CONFIG_FILE)),)
+$(error No exim configuration file specified, check your BR2_PACKAGE_EXIM_CUSTOM_CONFIG_FILE setting)
+endif
+define EXIM_CONFIGURE_CMDS
+       $(EXIM_USE_CUSTOM_CONFIG_FILE)
+       $(EXIM_CONFIGURE_TOOLCHAIN)
+endef
+else # CUSTOM_CONFIG
+define EXIM_CONFIGURE_CMDS
+       $(EXIM_USE_DEFAULT_CONFIG_FILE)
+       $(EXIM_CONFIGURE_TOOLCHAIN)
+endef
+endif # CUSTOM_CONFIG
+
 # exim needs a bit of love to build statically
 ifeq ($(BR2_PREFER_STATIC_LIB),y)
 EXIM_STATIC_FLAGS = LFLAGS="-pthread --static"