package/luarocks: luajit is now detected automatically by luarocks
authorFrancois Perrad <fperrad@gmail.com>
Sun, 22 Mar 2020 08:07:02 +0000 (09:07 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 11 Apr 2020 13:58:42 +0000 (15:58 +0200)
Since luarocks commit
https://github.com/luarocks/luarocks/commit/ffab9f32698431bb901b786460e4695806ebcf30,
available since luarocks v3.2.0, LuaJIT is now detected
automatically. It is therefore no longer necessary to explicitly
indicate in lua_interpreter that LuaJIT is used.

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/luarocks/luarocks.mk

index 123f8c0734dd7248a74d35262e8d137e336e2382..d48c95ced9a01eec379a86588e6a6c4b1d53bf37 100644 (file)
@@ -33,17 +33,10 @@ define HOST_LUAROCKS_CONFIGURE_CMDS
        cd $(@D) && ./configure $(HOST_LUAROCKS_CONF_OPTS)
 endef
 
-ifeq ($(BR2_PACKAGE_LUAJIT),y)
-define LUAROCKS_CONFIGURE_INTERPRETER_LUAJIT
-       echo "lua_interpreter = [[luajit]]" >> $(LUAROCKS_CONFIG_FILE)
-endef
-endif
-
 define HOST_LUAROCKS_INSTALL_CMDS
        rm -f $(LUAROCKS_CONFIG_FILE)
        $(MAKE1) -C $(@D) install
        cat $(HOST_LUAROCKS_PKGDIR)/luarocks-br-config.lua >> $(LUAROCKS_CONFIG_FILE)
-       $(LUAROCKS_CONFIGURE_INTERPRETER_LUAJIT)
 endef
 
 $(eval $(host-generic-package))