package/libdrm: adjust patch switching to pkg-config for libatomic_ops
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 7 Jan 2018 17:07:38 +0000 (18:07 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 7 Jan 2018 20:25:41 +0000 (21:25 +0100)
In commit fa6c7d165971e1f70b9ac94bae9cd1fd9180c072 ("libdrm: fix
libatomic_ops linking"), a patch was added to switch to
PKG_CHECK_MODULES() to detect libatomic_ops instead of
AC_CHECK_HEADER.

However, as explained in
https://autotools.io/pkgconfig/pkg_check_modules.html:

"In contrast with almost all of the original macros, though, the default
 action-if-not-found will end the execution with an error for not having
 found the dependency."

This makes the configure script bail out when libatomic_ops is not
available, which is not what we want in libdrm's configure
script. This commit adjusts the PKG_CHECK_MODULES() call to avoid
failing.

Fixes:

  http://autobuild.buildroot.net/results/cea/cea777dc997f86c1122c8b818d264215a0e77e5a/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libdrm/0003-configure-Makefile.am-use-pkg-config-to-discover-lib.patch

index 20bb0a36d36f813ce3a5ad916c63a8c22268bb59..0fbe77ef7c0cbb743d7d07cb4e3e494d164d71e1 100644 (file)
@@ -23,6 +23,8 @@ and we don't link against it.
 
 Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
 Signed-off-by: Peter Seiderer <ps.report@gmx.net>
+[Bernd: PKG_CHECK_MODULES should not fail when libatomic_ops is missing]
+Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
 ---
  amdgpu/Makefile.am    | 2 +-
  configure.ac          | 2 +-
@@ -57,7 +59,7 @@ index 35378b33..501d0871 100644
  
        if test "x$drm_cv_atomic_primitives" = "xnone"; then
 -              AC_CHECK_HEADER([atomic_ops.h], drm_cv_atomic_primitives="libatomic-ops")
-+              PKG_CHECK_MODULES(ATOMIC_OPS, [atomic_ops], drm_cv_atomic_primitives="libatomic-ops")
++              PKG_CHECK_MODULES(ATOMIC_OPS, [atomic_ops], drm_cv_atomic_primitives="libatomic-ops", true)
        fi
  
        # atomic functions defined in <atomic.h> & libc on Solaris