transmission: gtk option needs libgtk3
authorPeter Korsgaard <peter@korsgaard.com>
Fri, 1 Sep 2017 22:37:48 +0000 (00:37 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 1 Sep 2017 22:37:48 +0000 (00:37 +0200)
Fixes the following configure issue:

checking for GTK... no
configure: error: Package requirements (gtk+-3.0 >= 3.4.0
                              glib-2.0 >= 2.32.0
                              gio-2.0 >= 2.26.0,
                              gmodule-2.0 >= 2.32.0
                              gthread-2.0 >= 2.32.0) were not met:

libgtk2 support was dropped in commit cdd71c642724 ((trunk gtk) #4970 remove
deprecated GTK+ API calls, raise GTK+ dependency to 3.2) which was part of
transmission-2.61.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/transmission/Config.in
package/transmission/transmission.mk

index b47c36fdd3fa451759de3b6a3cde37a7d38f9407..38a459cdbe9f6c59236afada04f98a1bc1fda657 100644 (file)
@@ -39,12 +39,12 @@ config BR2_PACKAGE_TRANSMISSION_REMOTE
 
 config BR2_PACKAGE_TRANSMISSION_GTK
        bool "transmission-gtk"
-       depends on BR2_PACKAGE_LIBGTK2 && BR2_ENABLE_LOCALE
+       depends on BR2_PACKAGE_LIBGTK3 && BR2_ENABLE_LOCALE
        help
          Install transmission GTK-based GUI interface.
 
 comment "transmission-gtk needs a toolchain w/ locale"
-       depends on BR2_PACKAGE_LIBGTK2 && !BR2_ENABLE_LOCALE
+       depends on BR2_PACKAGE_LIBGTK3 && !BR2_ENABLE_LOCALE
 endif
 
 comment "transmission needs a toolchain w/ threads"
index f2333cb93e0b1ffd2d8714f8da92d1102abebb55..7f4675302ebdb09f1a84bdbe16e8a138517917b4 100644 (file)
@@ -83,7 +83,7 @@ endif
 
 ifeq ($(BR2_PACKAGE_TRANSMISSION_GTK),y)
 TRANSMISSION_CONF_OPTS += --with-gtk
-TRANSMISSION_DEPENDENCIES += libgtk2
+TRANSMISSION_DEPENDENCIES += libgtk3
 else
 TRANSMISSION_CONF_OPTS += --without-gtk
 endif