package/x11r7/xapp_xeyes: xrender is optional, not mandatory
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Tue, 14 Sep 2021 16:17:30 +0000 (18:17 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Tue, 14 Sep 2021 19:47:57 +0000 (21:47 +0200)
xrender is optional, not mandatory since its addition in version 1.0.99:
https://gitlab.freedesktop.org/xorg/app/xeyes/-/commit/5e825a140f4022b88dd7a1a20a9a01b653f1a95c

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/x11r7/xapp_xeyes/Config.in
package/x11r7/xapp_xeyes/xapp_xeyes.mk

index 5cf7f6c0523f2b1e0d7aef51c920ed999e98d309..a7b77375fdc3adefd673cbf596a3bface6326fff 100644 (file)
@@ -3,7 +3,6 @@ config BR2_PACKAGE_XAPP_XEYES
        select BR2_PACKAGE_XLIB_LIBX11
        select BR2_PACKAGE_XLIB_LIBXEXT
        select BR2_PACKAGE_XLIB_LIBXMU
-       select BR2_PACKAGE_XLIB_LIBXRENDER
        select BR2_PACKAGE_XLIB_LIBXT
        help
          X.Org xeyes application
index 11eea802d5b48ff663b9913b452c75836ee3fadb..a127e28ea7279ac81d061dfef0140cbfad51ea7b 100644 (file)
@@ -9,6 +9,13 @@ XAPP_XEYES_SOURCE = xeyes-$(XAPP_XEYES_VERSION).tar.bz2
 XAPP_XEYES_SITE = https://xorg.freedesktop.org/archive/individual/app
 XAPP_XEYES_LICENSE = MIT
 XAPP_XEYES_LICENSE_FILES = COPYING
-XAPP_XEYES_DEPENDENCIES = xlib_libX11 xlib_libXext xlib_libXmu xlib_libXrender xlib_libXt
+XAPP_XEYES_DEPENDENCIES = xlib_libX11 xlib_libXext xlib_libXmu xlib_libXt
+
+ifeq ($(BR2_PACKAGE_XLIB_LIBXRENDER),y)
+XAPP_XEYES_DEPENDENCIES += xlib_libXrender
+XAPP_XEYES_CONF_OPTS += --with-xrender
+else
+XAPP_XEYES_CONF_OPTS += --without-xrender
+endif
 
 $(eval $(autotools-package))