toolchain: introduce HOST_DIR option
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 2 Feb 2011 13:05:56 +0000 (10:05 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 2 Feb 2011 21:46:13 +0000 (22:46 +0100)
Allow the user to define HOST_DIR in the config menu.

This way when building an internal toolchain a separate (maybe shared)
output directory may be defined and the toolchain can be used by
multiple users and/or projects.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Config.in
Makefile

index 423499ae4c23b070edd639a726f560899694b980..af26bbebb9d591de1986cc78bbeed2a3500e1626 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -72,6 +72,16 @@ config BR2_DL_DIR
 
          The default is $(TOPDIR)/dl
 
+config BR2_HOST_DIR
+       string "Host dir"
+       default "$(BASE_DIR)/host"
+       help
+         Directory to store all the binary files that are built for the host.
+         This includes the cross compilation toolchain when building the
+         internal buildroot toolchain.
+
+         The default is $(BASE_DIR)/host
+
 menu "Mirrors and Download locations"
 
 config BR2_PRIMARY_SITE
index 956374082614b876dcea822db1dbed21b0aa20b5..914d2ed3672b4134390782d5b6339ffabc4f43ac 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -274,8 +274,8 @@ TAR_OPTIONS=$(call qstrip,$(BR2_TAR_OPTIONS)) -xf
 
 GNU_TARGET_SUFFIX:=-$(call qstrip,$(BR2_GNU_TARGET_SUFFIX))
 
-# packages compiled for the host goes here
-HOST_DIR:=$(BASE_DIR)/host
+# packages compiled for the host go here
+HOST_DIR:=$(call qstrip,$(BR2_HOST_DIR))
 
 # stamp (dependency) files go here
 STAMP_DIR:=$(BASE_DIR)/stamps