gcc: simplify musl patches for SSP support
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 17 Oct 2015 13:09:10 +0000 (15:09 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 18 Oct 2015 13:35:53 +0000 (15:35 +0200)
Now that we are always explicitly passing gcc_cv_libc_provides_ssp,
there is no longer any reason to modify the gcc configure/configure.ac
to take into account the musl case. When a musl toolchain is being
built, BR2_TOOLCHAIN_HAS_SSP is always 'y', and therefore
gcc_cv_libc_provides_ssp=yes is always passed when building
gcc-initial and gcc-final.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gcc/4.7.4/900-musl-support.patch
package/gcc/4.8.5/900-musl-support.patch
package/gcc/4.9.3/900-musl-support.patch
package/gcc/5.2.0/904-musl-libc-config.patch

index 1cb67010e000c2db7298229d6c5d5eabad178c68..67b8c30c1d959f2e3769c982582cad92ba322f6a 100644 (file)
@@ -323,24 +323,6 @@ Index: b/gcc/configure
 ===================================================================
 --- a/gcc/configure
 +++ b/gcc/configure
-@@ -26791,6 +26791,9 @@
- else
-   gcc_cv_libc_provides_ssp=no
-     case "$target" in
-+       *-*-musl*)
-+         # All versions of musl provide stack protector
-+       gcc_cv_libc_provides_ssp=yes;;
-        *-*-linux* | *-*-kfreebsd*-gnu | *-*-knetbsd*-gnu)
-       # glibc 2.4 and later provides __stack_chk_fail and
-       # either __stack_chk_guard, or TLS access to stack guard canary.
-@@ -26824,6 +26827,7 @@
-        # <http://gcc.gnu.org/ml/gcc/2008-10/msg00130.html>) and for now
-        # simply assert that glibc does provide this, which is true for all
-        # realistically usable GNU/Hurd configurations.
-+       # All supported versions of musl provide it as well
-        gcc_cv_libc_provides_ssp=yes;;
-        *-*-darwin* | *-*-freebsd*)
-        ac_fn_c_check_func "$LINENO" "__stack_chk_fail" "ac_cv_func___stack_chk_fail"
 @@ -26906,6 +26910,9 @@
        gcc_cv_target_dl_iterate_phdr=no
      fi
@@ -355,24 +337,6 @@ Index: b/gcc/configure.ac
 ===================================================================
 --- a/gcc/configure.ac
 +++ b/gcc/configure.ac
-@@ -4669,6 +4669,9 @@
-       gcc_cv_libc_provides_ssp,
-       [gcc_cv_libc_provides_ssp=no
-     case "$target" in
-+       *-*-musl*)
-+         # All versions of musl provide stack protector
-+       gcc_cv_libc_provides_ssp=yes;;
-        *-*-linux* | *-*-kfreebsd*-gnu | *-*-knetbsd*-gnu)
-       [# glibc 2.4 and later provides __stack_chk_fail and
-       # either __stack_chk_guard, or TLS access to stack guard canary.
-@@ -4702,6 +4705,7 @@
-        # <http://gcc.gnu.org/ml/gcc/2008-10/msg00130.html>) and for now
-        # simply assert that glibc does provide this, which is true for all
-        # realistically usable GNU/Hurd configurations.
-+       # All supported versions of musl provide it as well
-        gcc_cv_libc_provides_ssp=yes;;
-        *-*-darwin* | *-*-freebsd*)
-        AC_CHECK_FUNC(__stack_chk_fail,[gcc_cv_libc_provides_ssp=yes],
 @@ -4767,6 +4771,9 @@
        gcc_cv_target_dl_iterate_phdr=no
      fi
index 761f018f2198425a1b04787d58a9a4c61f02e6d3..6743a88b001691bc64b9291684aa3f0d9c4b61e3 100644 (file)
@@ -486,24 +486,6 @@ Index: b/gcc/configure
 ===================================================================
 --- a/gcc/configure
 +++ b/gcc/configure
-@@ -26821,6 +26821,9 @@
- else
-   gcc_cv_libc_provides_ssp=no
-     case "$target" in
-+       *-*-musl*)
-+         # All versions of musl provide stack protector
-+       gcc_cv_libc_provides_ssp=yes;;
-        *-*-linux* | *-*-kfreebsd*-gnu | *-*-knetbsd*-gnu)
-       # glibc 2.4 and later provides __stack_chk_fail and
-       # either __stack_chk_guard, or TLS access to stack guard canary.
-@@ -26854,6 +26857,7 @@
-        # <http://gcc.gnu.org/ml/gcc/2008-10/msg00130.html>) and for now
-        # simply assert that glibc does provide this, which is true for all
-        # realistically usable GNU/Hurd configurations.
-+       # All supported versions of musl provide it as well
-        gcc_cv_libc_provides_ssp=yes;;
-        *-*-darwin* | *-*-freebsd*)
-        ac_fn_c_check_func "$LINENO" "__stack_chk_fail" "ac_cv_func___stack_chk_fail"
 @@ -26936,6 +26940,9 @@
        gcc_cv_target_dl_iterate_phdr=no
      fi
@@ -518,24 +500,6 @@ Index: b/gcc/configure.ac
 ===================================================================
 --- a/gcc/configure.ac
 +++ b/gcc/configure.ac
-@@ -4750,6 +4750,9 @@
-       gcc_cv_libc_provides_ssp,
-       [gcc_cv_libc_provides_ssp=no
-     case "$target" in
-+       *-*-musl*)
-+         # All versions of musl provide stack protector
-+       gcc_cv_libc_provides_ssp=yes;;
-        *-*-linux* | *-*-kfreebsd*-gnu | *-*-knetbsd*-gnu)
-       [# glibc 2.4 and later provides __stack_chk_fail and
-       # either __stack_chk_guard, or TLS access to stack guard canary.
-@@ -4783,6 +4786,7 @@
-        # <http://gcc.gnu.org/ml/gcc/2008-10/msg00130.html>) and for now
-        # simply assert that glibc does provide this, which is true for all
-        # realistically usable GNU/Hurd configurations.
-+       # All supported versions of musl provide it as well
-        gcc_cv_libc_provides_ssp=yes;;
-        *-*-darwin* | *-*-freebsd*)
-        AC_CHECK_FUNC(__stack_chk_fail,[gcc_cv_libc_provides_ssp=yes],
 @@ -4848,6 +4852,9 @@
        gcc_cv_target_dl_iterate_phdr=no
      fi
index 56502b882c650e52dfadc0d64ca128f2d6c83e3b..a711b068e06af4e7d4a1ce370717c1e93d183957 100644 (file)
@@ -452,24 +452,6 @@ Index: b/gcc/configure
 ===================================================================
 --- a/gcc/configure
 +++ b/gcc/configure
-@@ -27328,6 +27328,9 @@
- else
-   gcc_cv_libc_provides_ssp=no
-     case "$target" in
-+       *-*-musl*)
-+         # All versions of musl provide stack protector
-+       gcc_cv_libc_provides_ssp=yes;;
-        *-*-linux* | *-*-kfreebsd*-gnu | *-*-knetbsd*-gnu)
-       # glibc 2.4 and later provides __stack_chk_fail and
-       # either __stack_chk_guard, or TLS access to stack guard canary.
-@@ -27360,6 +27363,7 @@
-        # <http://gcc.gnu.org/ml/gcc/2008-10/msg00130.html>) and for now
-        # simply assert that glibc does provide this, which is true for all
-        # realistically usable GNU/Hurd configurations.
-+       # All supported versions of musl provide it as well
-        gcc_cv_libc_provides_ssp=yes;;
-        *-*-darwin* | *-*-freebsd*)
-        ac_fn_c_check_func "$LINENO" "__stack_chk_fail" "ac_cv_func___stack_chk_fail"
 @@ -27449,6 +27453,9 @@
        gcc_cv_target_dl_iterate_phdr=no
      fi
@@ -484,24 +466,6 @@ Index: b/gcc/configure.ac
 ===================================================================
 --- a/gcc/configure.ac
 +++ b/gcc/configure.ac
-@@ -5016,6 +5016,9 @@
-       gcc_cv_libc_provides_ssp,
-       [gcc_cv_libc_provides_ssp=no
-     case "$target" in
-+       *-*-musl*)
-+         # All versions of musl provide stack protector
-+       gcc_cv_libc_provides_ssp=yes;;
-        *-*-linux* | *-*-kfreebsd*-gnu | *-*-knetbsd*-gnu)
-       # glibc 2.4 and later provides __stack_chk_fail and
-       # either __stack_chk_guard, or TLS access to stack guard canary.
-@@ -5042,6 +5045,7 @@
-        # <http://gcc.gnu.org/ml/gcc/2008-10/msg00130.html>) and for now
-        # simply assert that glibc does provide this, which is true for all
-        # realistically usable GNU/Hurd configurations.
-+       # All supported versions of musl provide it as well
-        gcc_cv_libc_provides_ssp=yes;;
-        *-*-darwin* | *-*-freebsd*)
-        AC_CHECK_FUNC(__stack_chk_fail,[gcc_cv_libc_provides_ssp=yes],
 @@ -5108,6 +5112,9 @@
        gcc_cv_target_dl_iterate_phdr=no
      fi
index c4eddb408dcad4ea406fddecf6dd017f3fa58999..85491406cf7f39bab940d0ea37fc2b597f2577ba 100644 (file)
@@ -225,24 +225,6 @@ Index: b/gcc/configure
 ===================================================================
 --- a/gcc/configure
 +++ b/gcc/configure
-@@ -27681,6 +27681,9 @@
- else
-   gcc_cv_libc_provides_ssp=no
-     case "$target" in
-+       *-*-musl*)
-+       # All versions of musl provide stack protector
-+       gcc_cv_libc_provides_ssp=yes;;
-        *-*-linux* | *-*-kfreebsd*-gnu | *-*-knetbsd*-gnu)
-       # glibc 2.4 and later provides __stack_chk_fail and
-       # either __stack_chk_guard, or TLS access to stack guard canary.
-@@ -27713,6 +27716,7 @@
-        # <http://gcc.gnu.org/ml/gcc/2008-10/msg00130.html>) and for now
-        # simply assert that glibc does provide this, which is true for all
-        # realistically usable GNU/Hurd configurations.
-+       # All supported versions of musl provide it as well
-        gcc_cv_libc_provides_ssp=yes;;
-        *-*-darwin* | *-*-freebsd*)
-        ac_fn_c_check_func "$LINENO" "__stack_chk_fail" "ac_cv_func___stack_chk_fail"
 @@ -27809,6 +27813,9 @@
        gcc_cv_target_dl_iterate_phdr=no
      fi
@@ -257,24 +239,6 @@ Index: b/gcc/configure.ac
 ===================================================================
 --- a/gcc/configure.ac
 +++ b/gcc/configure.ac
-@@ -5199,6 +5199,9 @@
-       gcc_cv_libc_provides_ssp,
-       [gcc_cv_libc_provides_ssp=no
-     case "$target" in
-+       *-*-musl*)
-+       # All versions of musl provide stack protector
-+       gcc_cv_libc_provides_ssp=yes;;
-        *-*-linux* | *-*-kfreebsd*-gnu | *-*-knetbsd*-gnu)
-       # glibc 2.4 and later provides __stack_chk_fail and
-       # either __stack_chk_guard, or TLS access to stack guard canary.
-@@ -5225,6 +5228,7 @@
-        # <http://gcc.gnu.org/ml/gcc/2008-10/msg00130.html>) and for now
-        # simply assert that glibc does provide this, which is true for all
-        # realistically usable GNU/Hurd configurations.
-+       # All supported versions of musl provide it as well
-        gcc_cv_libc_provides_ssp=yes;;
-        *-*-darwin* | *-*-freebsd*)
-        AC_CHECK_FUNC(__stack_chk_fail,[gcc_cv_libc_provides_ssp=yes],
 @@ -5298,6 +5302,9 @@
        gcc_cv_target_dl_iterate_phdr=no
      fi