package/mtd-utils: fix git build after gitweb update
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 14 Dec 2009 12:31:50 +0000 (13:31 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 14 Dec 2009 12:34:27 +0000 (13:34 +0100)
Reported by Daniel Mack <daniel@caiaq.de>

The gitweb installation of infradead.org has been updated, and gitweb >=
1.6.6-rc1 adds the first 7 characters of the git SHA1 to the snapshot
tarball directory name.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/mtd/mtd-utils.git/mtd.mk

diff --git a/CHANGES b/CHANGES
index b31d5dc186f10db7aa6705d9ea70409ee8dd8f2c..5217452cf99ee189689e7bfd3d42ef6283919ab5 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -4,7 +4,7 @@
 
        Updated/fixed packages: autoconf, bind, binutils, busybox,
        directfb, gst-plugins-bad, iw, libfuse, libpcap, lighttpd,
-       mesa, pcre, sshfs, tremor, usbutils
+       mesa, mtd-utils, pcre, sshfs, tremor, usbutils
 
        Issues resolved (http://bugs.uclibc.org):
 
index b7e584ea5b25922e4c042c814a093f74f5be63c0..6cb45c29e4aca7a4c1909634f5b806257cf67143 100644 (file)
@@ -4,12 +4,14 @@
 #
 #############################################################
 MTD_VERSION:=fcb52ccc99679460640386c297023f852b108f68
+# gitweb >= 1.6.6-rc1 uses first 7 chars of git SHA1 as dir suffix
+MTD_SHORT_VERSION=$(shell echo $(MTD_VERSION)|cut -c -7)
 MTD_SOURCE:=mtd-utils-$(MTD_VERSION).tar.gz
 MTD_URL:=http://git.infradead.org/mtd-utils.git?a=snapshot;h=$(MTD_VERSION);sf=tgz
 MTD_HOST_DIR:= $(TOOLCHAIN_DIR)/mtd-utils-$(MTD_VERSION)
 MTD_DIR:=$(BUILD_DIR)/mtd-utils-$(MTD_VERSION)
 MTD_CAT:=$(ZCAT)
-MTD_NAME:=mtd-utils
+MTD_NAME:=mtd-utils-$(MTD_SHORT_VERSION)
 
 #############################################################
 #