package/log4cplus: link with libatomic when needed
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 17 Feb 2019 09:33:26 +0000 (10:33 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 17 Feb 2019 15:00:00 +0000 (16:00 +0100)
On some architectures, atomic binutils are provided by the libatomic
library from gcc. Linking with libatomic is therefore necessary,
otherwise the build fails with:

sparc-buildroot-linux-uclibc/sysroot/lib/libatomic.so.1: error adding symbols: DSO missing from command line

This is often for example the case on sparcv8 32 bit.

Fixes:
 - http://autobuild.buildroot.org/results/16e360cb91afff7655f459a3d1fb906ca48f8464

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/log4cplus/log4cplus.mk

index 22efde2fd6fc7d5a6daeb8c47c64565a48911ce8..0bc4fc9aa697cc3b52330a5b343a146f094f83c6 100644 (file)
@@ -11,4 +11,8 @@ LOG4CPLUS_LICENSE = Apache-2.0, BSD-2-Clause, BSD-like (threadpool)
 LOG4CPLUS_LICENSE_FILES = LICENSE
 LOG4CPLUS_INSTALL_STAGING = YES
 
+ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
+LOG4CPLUS_CONF_ENV += LIBS='-latomic'
+endif
+
 $(eval $(autotools-package))