package/refpolicy: ensure REFPOLICY_EXTRA_MODULES_DIRS is empty when it should be
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 4 Sep 2020 15:19:16 +0000 (17:19 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 4 Sep 2020 15:19:16 +0000 (17:19 +0200)
When both BR2_REFPOLICY_EXTRA_MODULES_DIRS and
PACKAGES_SELINUX_EXTRA_MODULES_DIRS are empty, we expect
REFPOLICY_EXTRA_MODULES_DIRS to also be empty. However, due to spaces,
this is not the case. This commit adds a $(strip ...) call to ensure
it is the case.

Thanks to this, the check on whether REFPOLICY_EXTRA_MODULES_DIRS is
empty later on will really work as it should.

Reported-by: Antoine Ténart <antoine.tenart@bootlin.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/refpolicy/refpolicy.mk

index edfbb3542c38d68d87f60d8c64db04144e4fb7d3..e1924f3c2d952360f477668e3dd0d69e94faa64b 100644 (file)
@@ -42,8 +42,9 @@ ifeq ($(BR2_PACKAGE_REFPOLICY_UPSTREAM_VERSION),y)
 # Allow to provide out-of-tree SELinux modules in addition to the ones
 # in the refpolicy.
 REFPOLICY_EXTRA_MODULES_DIRS = \
-       $(call qstrip,$(BR2_REFPOLICY_EXTRA_MODULES_DIRS)) \
-       $(PACKAGES_SELINUX_EXTRA_MODULES_DIRS)
+       $(strip \
+               $(call qstrip,$(BR2_REFPOLICY_EXTRA_MODULES_DIRS)) \
+               $(PACKAGES_SELINUX_EXTRA_MODULES_DIRS))
 $(foreach dir,$(REFPOLICY_EXTRA_MODULES_DIRS),\
        $(if $(wildcard $(dir)),,\
                $(error BR2_REFPOLICY_EXTRA_MODULES_DIRS contains nonexistent directory $(dir))))