package/libebur128: new package
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 24 Jul 2016 15:53:17 +0000 (17:53 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 24 Jul 2016 19:53:20 +0000 (21:53 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/libebur128/Config.in [new file with mode: 0644]
package/libebur128/libebur128.mk [new file with mode: 0644]

index 181921b335f928a67ebbdc2fba95364afd66c10d..04ca8cb3d6f29883d077aac1972a9ac13b84fd1d 100644 (file)
@@ -816,6 +816,7 @@ menu "Audio/Sound"
        source "package/libcodec2/Config.in"
        source "package/libcue/Config.in"
        source "package/libcuefile/Config.in"
+       source "package/libebur128/Config.in"
        source "package/libg7221/Config.in"
        source "package/libid3tag/Config.in"
        source "package/libilbc/Config.in"
diff --git a/package/libebur128/Config.in b/package/libebur128/Config.in
new file mode 100644 (file)
index 0000000..1a6a743
--- /dev/null
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_LIBEBUR128
+       bool "libebur128"
+       # build system has no support to disable shared linking
+       # leading to a build error with a static-only toolchain
+       depends on !BR2_STATIC_LIBS
+       select BR2_PACKAGE_SPEEX
+       help
+         libebur128 is a library that implements the EBU R 128 standard
+         for loudness normalization.
+
+         https://github.com/jiixyj/libebur128
+
+comment "libebur128 needs a toolchain w/ dynamic library"
+       depends on BR2_STATIC_LIBS
diff --git a/package/libebur128/libebur128.mk b/package/libebur128/libebur128.mk
new file mode 100644 (file)
index 0000000..f5ada31
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# libebur128
+#
+################################################################################
+
+LIBEBUR128_VERSION = v1.1.0
+LIBEBUR128_SITE = $(call github,jiixyj,libebur128,$(LIBEBUR128_VERSION))
+LIBEBUR128_LICENSE = MIT
+LIBEBUR128_LICENSE_FILES = COPYING
+LIBEBUR128_INSTALL_STAGING = YES
+LIBEBUR128_DEPENDENCIES = speex
+
+$(eval $(cmake-package))