package/alure: add opus decoder option
authorRomain Naour <romain.naour@gmail.com>
Sun, 5 Jan 2020 11:32:01 +0000 (12:32 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 12 Jan 2020 20:21:02 +0000 (21:21 +0100)
The opus option is available only when libogg is
detected by the build system.

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/alure/Config.in
package/alure/alure.mk

index df86ff2a92ed6219b77443c27bd7976ef9ed7aa5..7947e30a1f5e163360f5bb6335007965e14af639 100644 (file)
@@ -23,6 +23,13 @@ config BR2_PACKAGE_ALURE_FLAC_DECODER
        help
          Enables the built-in FLAC decoder.
 
+config BR2_PACKAGE_ALURE_OPUS_DECODER
+       bool "opus decoder"
+       select BR2_PACKAGE_LIBOGG
+       select BR2_PACKAGE_OPUS
+       help
+         Enables the built-in libopusfile decoder.
+
 endif
 
 comment "alure needs a toolchain w/ C++, gcc >= 4.9, NPTL, wchar"
index afcc333683141e24c399af37c90a61115289d681..8d01282ccfa2c1d092207cfa0d58e328dccedb36 100644 (file)
@@ -17,7 +17,6 @@ ALURE_DEPENDENCIES = openal
 ALURE_CONF_OPTS = -DALURE_INSTALL=ON \
        -DALURE_BUILD_EXAMPLES=OFF \
        -DALURE_ENABLE_MINIMP3=OFF \
-       -DALURE_ENABLE_OPUS=OFF \
        -DALURE_ENABLE_SNDFILE=OFF \
        -DALURE_ENABLE_VORBIS=OFF \
        -DALURE_ENABLE_WAVE=ON
@@ -28,6 +27,13 @@ else
 ALURE_CONF_OPTS += -DALURE_ENABLE_FLAC=OFF
 endif
 
+ifeq ($(BR2_PACKAGE_ALURE_OPUS_DECODER),y)
+ALURE_CONF_OPTS += -DALURE_ENABLE_OPUS=ON
+ALURE_DEPENDENCIES += libogg opus
+else
+ALURE_CONF_OPTS += -DALURE_ENABLE_OPUS=OFF
+endif
+
 ifeq ($(BR2_STATIC_LIBS),y)
 ALURE_CONF_OPTS += -DALURE_BUILD_SHARED=OFF \
        -DALURE_BUILD_STATIC=ON