libv4l: needs iconv
authorPeter Seiderer <ps.report@gmx.net>
Thu, 23 Oct 2014 21:22:36 +0000 (23:22 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 24 Oct 2014 23:17:14 +0000 (01:17 +0200)
Fixes:
 http://autobuild.buildroot.net/results/901/901ed0092ee0411ba77a6f1f46d161621569c7f7/

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libv4l/Config.in
package/libv4l/libv4l.mk

index 866f8c67e3ac8e283811c8afed889a67dd9f1a7f..04f0c6a9b3059dde522aeb65d825ba594070afad 100644 (file)
@@ -5,6 +5,7 @@ config BR2_PACKAGE_LIBV4L
        depends on BR2_USE_MMU # fork()
        depends on BR2_INSTALL_LIBSTDCPP
        select BR2_PACKAGE_ARGP_STANDALONE if BR2_TOOLCHAIN_USES_UCLIBC
+       select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
        help
          libv4l is a collection of libraries which adds a thin abstraction
          layer on top of video4linux2 devices. libv4l consists of 3 different
index 0512e4912bf95c01a4a241738456e49b64569b94..732fad5008ae8f9964179beec7cb596142f1ccee 100644 (file)
@@ -20,6 +20,8 @@ LIBV4L_DEPENDENCIES += argp-standalone
 LIBV4L_CONF_ENV += LIBS="-largp"
 endif
 
+LIBV4L_DEPENDENCIES += $(if $(BR2_PACKAGE_LIBICONV),libiconv)
+
 ifeq ($(BR2_PACKAGE_JPEG),y)
 LIBV4L_DEPENDENCIES += jpeg
 LIBV4L_CONF_OPTS += --with-jpeg