package/wget: add optional dependency to libiconv
authorBernd Kuhls <bernd.kuhls@t-online.de>
Mon, 16 Mar 2020 19:15:27 +0000 (20:15 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 12 Apr 2020 13:49:05 +0000 (15:49 +0200)
wget has an optional dependency to libiconv:
http://git.savannah.gnu.org/cgit/wget.git/tree/configure.ac#n344

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/wget/wget.mk

index 7b9c3e75d96d3348328dda408e1eebd452bdb62c..ed3f1fdff90053b8d0119843d6f5477fda4a7a1a 100644 (file)
@@ -21,6 +21,10 @@ else
 WGET_CONF_OPTS += --without-ssl
 endif
 
+ifeq ($(BR2_PACKAGE_LIBICONV),y)
+WGET_DEPENDENCIES += libiconv
+endif
+
 ifeq ($(BR2_PACKAGE_LIBIDN2),y)
 WGET_CONF_OPTS += --with-libidn
 WGET_DEPENDENCIES += libidn2