package/mono: fixing missing locale
authorAngelo Compagnucci <angelo.compagnucci@gmail.com>
Mon, 27 Jul 2015 10:06:24 +0000 (12:06 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 27 Jul 2015 21:19:55 +0000 (23:19 +0200)
This patch fixes compilation error in case of a missing locale in toolchain.

Fixes: http://autobuild.buildroot.net/results/a0fc33a4ed90844f9529acc76a6ba183fe253771/
       http://autobuild.buildroot.net/results/3ff839e894f0b8f9c2e3af9629d45e8efc09aecd/
       http://autobuild.buildroot.net/results/5e11117048d965bc1fc44c738bb51f11164304af/

Signed-off-by: Angelo Compagnucci <angelo.compagnucci@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mono/Config.in
package/mono/mono.mk

index 4445f4b010ab78e295f5197fa7dd90cdcfc6cd4f..0c7129b91ac5a5396357595b3e04fb1f791a2870 100644 (file)
@@ -7,6 +7,7 @@ config BR2_PACKAGE_MONO
        bool "mono"
        depends on BR2_PACKAGE_MONO_ARCH_SUPPORTS
        depends on BR2_TOOLCHAIN_HAS_THREADS
+       select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
        help
          An open source, cross-platform, implementation of C#
          and the CLR that is binary compatible with Microsoft.NET.
index 9cb8564109ba4a5617997d8f95484a2809b846d4..8668aa0d05592a2cb7ddca93a2aa6b5da72a7d09 100644 (file)
@@ -36,6 +36,10 @@ endef
 
 MONO_POST_INSTALL_TARGET_HOOKS += MONO_INSTALL_LIBS
 
+ifeq ($(BR2_PACKAGE_LIBICONV),y)
+MONO_DEPENDENCIES += libiconv
+endif
+
 MONO_DEPENDENCIES += host-mono
 
 ## Mono managed