gcc on target: add missing definitions for gcc 4.4
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 25 Feb 2010 08:44:57 +0000 (09:44 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 25 Feb 2010 08:47:01 +0000 (09:47 +0100)
Depending on the gcc version, the gcc include and lib directories have
changed. We include support for gcc 4.4 by copy/pasting the support
for gcc 4.3. Locations don't seem to have changed between 4.3 and
4.4. This allows the syslimits.h fixup to succeed.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
toolchain/gcc/gcc-uclibc-4.x.mk

index 6f65cb35fbd616e6d115eb10d9b4fc3e3733bafa..dcca431dba9a54e40645b856025b6f4c14e207ef 100644 (file)
@@ -459,6 +459,10 @@ ifeq ($(findstring x4.3,x$(GCC_VERSION)),x4.3)
 GCC_LIB_SUBDIR=lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)
 GCC_INCLUDE_DIR:=include-fixed
 endif
+ifeq ($(findstring x4.4,x$(GCC_VERSION)),x4.4)
+GCC_LIB_SUBDIR=lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)
+GCC_INCLUDE_DIR:=include-fixed
+endif
 
 $(TARGET_DIR)/usr/bin/gcc: $(GCC_BUILD_DIR3)/.compiled
        PATH=$(TARGET_PATH) DESTDIR=$(TARGET_DIR) \