python, python3: build with tzset support
authorHenry Margies <henry.margies@gmail.com>
Wed, 9 Jul 2014 10:38:59 +0000 (11:38 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 15 Jul 2014 18:39:09 +0000 (20:39 +0200)
This patch adds support for time.tzset() in Python 2.7 and Python 3.

The Python configure script sets ac_cv_working_tzset to 'no' when
cross compiling, although it should be available and work with all
toolchains supported by Buildroot (?).
The patch below pre-sets the variable so that time.tzset() works.

[Thomas: adjust commit log.]

Signed-off-by: Henry Margies <henry.margies@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/python/python.mk
package/python3/python3.mk

index cb54e3e9654efbf85264e952937c5ec465297c0e..b2378486750ef6ed139c8d03fd58da226a531fd4 100644 (file)
@@ -121,7 +121,8 @@ endif
 PYTHON_CONF_ENV += \
        ac_cv_have_long_long_format=yes \
        ac_cv_file__dev_ptmx=yes \
-       ac_cv_file__dev_ptc=yes
+       ac_cv_file__dev_ptc=yes \
+       ac_cv_working_tzset=yes
 
 PYTHON_CONF_OPT += \
        --without-cxx-main      \
index 98fc31b6f84503436dc34facfe6b31750d00d1e4..1591ac9154c32ad69c71b0be55ca383ee4f61e6c 100644 (file)
@@ -96,6 +96,7 @@ PYTHON3_CONF_ENV += \
        ac_cv_have_long_long_format=yes \
        ac_cv_file__dev_ptmx=yes \
        ac_cv_file__dev_ptc=yes \
+       ac_cv_working_tzset=yes
 
 PYTHON3_CONF_OPT += \
        --without-ensurepip     \