netsnmp: Make server and client installation optional
authorStefan Sørensen <stefan.sorensen@spectralink.com>
Tue, 17 Feb 2015 15:42:39 +0000 (16:42 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 19 Feb 2015 22:17:14 +0000 (23:17 +0100)
The netsnmp package consists of both a server and a number of client
tools, this makes the installation of both parts optional.

[Thomas:
  - Add explicit --enable-{agent,applications}, and use positive logic.
  - Remove "net-snmp" from the new Config.in option prompts, since
    they are already visible under the netsnmp package option.]

Signed-off-by: Stefan Sørensen <stefan.sorensen@spectralink.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/netsnmp/Config.in
package/netsnmp/netsnmp.mk

index 8edbd3944691f34621cdfead875d107a7fc35135..589f720fa0e9c43f99215ac620bd638e899495f7 100644 (file)
@@ -9,6 +9,18 @@ config BR2_PACKAGE_NETSNMP
 
 if BR2_PACKAGE_NETSNMP
 
+config BR2_PACKAGE_NETSNMP_SERVER
+       bool "server"
+       default y
+       help
+         The snmpd server.
+
+config BR2_PACKAGE_NETSNMP_CLIENTS
+       bool "clients"
+       default y
+       help
+         The net-snmp clients (snmpget, snmpwalk, etc).
+
 config BR2_PACKAGE_NETSNMP_ENABLE_MIBS
        bool "Install MIB files on target and enable MIB loading code"
        default y
index bfc2a74a97fe55a1a10b3ec2b4ae3044951b3cde..58b52ef6f28027ed22f79d11ea975e8a262ab2a9 100644 (file)
@@ -67,6 +67,18 @@ ifneq ($(BR2_PACKAGE_NETSNMP_ENABLE_DEBUGGING),y)
        NETSNMP_CONF_OPTS += --disable-debugging
 endif
 
+ifeq ($(BR2_PACKAGE_NETSNMP_SERVER),y)
+       NETSNMP_CONF_OPTS += --enable-agent
+else
+       NETSNMP_CONF_OPTS += --disable-agent
+endif
+
+ifeq ($(BR2_PACKAGE_NETSNMP_CLIENTS),y)
+       NETSNMP_CONF_OPTS += --enable-applications
+else
+       NETSNMP_CONF_OPTS += --disable-applications
+endif
+
 # Remove IPv6 MIBs if there's no IPv6
 ifneq ($(BR2_INET_IPV6),y)
 define NETSNMP_REMOVE_MIBS_IPV6
@@ -84,10 +96,12 @@ endef
 
 NETSNMP_POST_INSTALL_TARGET_HOOKS += NETSNMP_REMOVE_BLOAT_MIBS
 
+ifeq ($(BR2_PACKAGE_NETSNMP_SERVER),y)
 define NETSNMP_INSTALL_INIT_SYSV
        $(INSTALL) -D -m 0755 package/netsnmp/S59snmpd \
                $(TARGET_DIR)/etc/init.d/S59snmpd
 endef
+endif
 
 define NETSNMP_STAGING_NETSNMP_CONFIG_FIXUP
        $(SED)  "s,^includedir=.*,includedir=\'$(STAGING_DIR)/usr/include\',g" \