package/iptraf-ng: bump to version 1.2.1
authorJugurtha BELKALEM <jugurtha.belkalem@smile.fr>
Wed, 19 Aug 2020 10:41:31 +0000 (12:41 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 25 Aug 2020 07:14:24 +0000 (09:14 +0200)
IPTraf-ng is a console-based network monitoring program for Linux that
displays information about IP traffic. It returns such information as:

- Current TCP connections
- UDP, ICMP, OSPF, and other types of IP packets
- Packet and byte counts on TCP connections
- IP, TCP, UDP, ICMP, non-IP, and other packet and byte counts
- TCP/UDP counts by ports
- Packet counts by packet sizes
- Packet and byte counts by IP address
- Interface activity
- Flag statuses on TCP packets
- LAN station statistics

V1.2.1 fixed multiple issues in V1.1.4 like :
- Introduce packet capturing abstraction: add recvmmsg(),
  TPACKET_V2 and TPACKET_V3 to capture in multigigabit speeds.
- Handling mlock() failures and carry on execution (without
  crashing iptraf-ng).
- Properly account non-IP packets.
- Show dropped packet count.

Signed-off-by: Jugurtha BELKALEM <jugurtha.belkalem@smile.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/iptraf-ng/Config.in
package/iptraf-ng/iptraf-ng.hash
package/iptraf-ng/iptraf-ng.mk

index 5c3b4848b91a349d2b0607f6e654bdc94e97c32b..f240daf93d9d0dea7f164439af8dd1cd79ef12dc 100644 (file)
@@ -3,11 +3,10 @@ config BR2_PACKAGE_IPTRAF_NG
        depends on BR2_USE_MMU # fork()
        select BR2_PACKAGE_NCURSES
        help
-         IPTraf-ng is a ncurses-based network monitoring utility. It
-         gathers data like TCP connection packet and byte counts,
-         interface statistics and activity indicators.
+         IPTraf-ng is a console-based network monitoring program for
+         Linux that gathers displays information about IP traffic.
 
-         https://fedorahosted.org/iptraf-ng/
+         https://github.com/iptraf-ng/iptraf-ng
 
          IPTraf-ng is a fork of original IPTraf v3.0.0
          (http://iptraf.seul.org).
index 0a257ec2fdc2ea1b320e454dc752ab02b85522f6..314d5cee29b75ec24b6484463fdbfd9a2af418c9 100644 (file)
@@ -1,4 +1,3 @@
-# From https://fedorahosted.org/releases/i/p/iptraf-ng/iptraf-ng-1.1.4.tar.gz.sum
-sha1   a2e51b0dd6b8c80583fc25d055850c96b3d2f544        iptraf-ng-1.1.4.tar.gz
 # Locally computed
+sha256  9f5cef584065420dea1ba32c86126aede1fa9bd25b0f8362b0f9fd9754f00870  iptraf-ng-1.2.1.tar.gz
 sha256  4e49bef38f621aac4a870da4b30011c7b7abc7256b218daec1c425b08448ae1e  LICENSE
index ac572b9eef9f761420d5149ecc2762fdab38e935..044630be414f9d10e34726830ab4cb38f0320c83 100644 (file)
@@ -4,16 +4,21 @@
 #
 ################################################################################
 
-IPTRAF_NG_VERSION = 1.1.4
-IPTRAF_NG_SITE = https://fedorahosted.org/releases/i/p/iptraf-ng
+IPTRAF_NG_VERSION = 1.2.1
+IPTRAF_NG_SITE = $(call github,iptraf-ng,iptraf-ng,v$(IPTRAF_NG_VERSION))
 IPTRAF_NG_LICENSE = GPL-2.0+
 IPTRAF_NG_LICENSE_FILES = LICENSE
 IPTRAF_NG_DEPENDENCIES = ncurses
 
-IPTRAF_NG_MAKE_ENV = \
-       NCURSES_LDFLAGS="-lpanel -lncurses"
+define IPTRAF_NG_BUILD_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) \
+               NCURSES_LDFLAGS="-lpanel -lncurses" \
+               -C $(@D)
+endef
 
-IPTRAF_NG_CONF_ENV = \
-       CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE"
+define IPTRAF_NG_INSTALL_TARGET_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
+               prefix=/usr DESTDIR=$(TARGET_DIR) install
+endef
 
-$(eval $(autotools-package))
+$(eval $(generic-package))