package/qt5base: install arch-specific configuration
authorYann E. MORIN <yann.morin.1998@free.fr>
Wed, 17 May 2017 21:15:28 +0000 (23:15 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 8 Jun 2017 21:19:36 +0000 (23:19 +0200)
For some architectures, it is necessary to link with additional
libraries, such as -latomic for sparc.

Add a bit of support to make that easy; actual use will be introduced in
the following patch.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Julien Corjon <corjon.j@ecagroup.com>
Cc: Peter Seiderer <ps.report@gmx.net>
Tested-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/qt5/qt5base/qmake.conf
package/qt5/qt5base/qt5base.mk

index 49cf89831667d30e8bab4cc1316dd68e72bdf7df..8b6debe58376282561a06c186a74ac9caed63c5f 100644 (file)
@@ -21,5 +21,8 @@ CONFIG                 += nostrip
 QMAKE_LIBS             += -lrt -lpthread -ldl
 QMAKE_CFLAGS_ISYSTEM   =
 
+# Architecturespecific configuration
+include(arch.conf)
+
 include(../common/linux_device_post.conf)
 load(qt_config)
index 0c088350e547ef25124a034a2996395ab447f658..81774b74a6d11fd0014c82209c5897f71c4c1681 100644 (file)
@@ -214,12 +214,15 @@ define QT5BASE_CONFIGURE_CONFIG_FILE
 endef
 endif
 
+QT5BASE_ARCH_CONFIG_FILE = $(@D)/mkspecs/devices/linux-buildroot-g++/arch.conf
 define QT5BASE_CONFIGURE_CMDS
        $(INSTALL) -m 0644 -D $(QT5BASE_PKGDIR)/qmake.conf \
                $(@D)/mkspecs/devices/linux-buildroot-g++/qmake.conf
        $(INSTALL) -m 0644 -D $(QT5BASE_PKGDIR)/qplatformdefs.h \
                $(@D)/mkspecs/devices/linux-buildroot-g++/qplatformdefs.h
        $(QT5BASE_CONFIGURE_CONFIG_FILE)
+       touch $(QT5BASE_ARCH_CONFIG_FILE)
+       $(QT5BASE_CONFIGURE_ARCH_CONFIG)
        (cd $(@D); \
                $(TARGET_MAKE_ENV) \
                PKG_CONFIG="$(PKG_CONFIG_HOST_BINARY)" \