package/gawk: clean the mpfr dependency
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 6 Dec 2015 11:13:58 +0000 (12:13 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 13 Dec 2015 15:01:18 +0000 (16:01 +0100)
When available, mpfr provides support for BIGNUM, which allows gawk to
work on arbitrarily-large numbers (hence the name).

Forcibly disable mpfr if the mpfr package is not enabled. Let
./configure find it automatically when it is enabled.

To be noted, the host-gawk need not have BIGNUM to build the target
variant with support for BIGNUM.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Peter Korsgaard <jacmet@uclibc.org>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gawk/gawk.mk

index 6702c486c5f4bd42fc6e2d9717670c39f8f35644..0fd131d8526d665ecd525521261ce0f64dce9184 100644 (file)
@@ -7,7 +7,7 @@
 GAWK_VERSION = 4.1.3
 GAWK_SOURCE = gawk-$(GAWK_VERSION).tar.xz
 GAWK_SITE = $(BR2_GNU_MIRROR)/gawk
-GAWK_DEPENDENCIES = host-gawk $(if $(BR2_PACKAGE_MPFR),mpfr)
+GAWK_DEPENDENCIES = host-gawk
 GAWK_LICENSE = GPLv3+
 GAWK_LICENSE_FILES = COPYING
 
@@ -16,6 +16,14 @@ ifeq ($(BR2_PACKAGE_BUSYBOX),y)
 GAWK_DEPENDENCIES += busybox
 endif
 
+# --with-mpfr requires an argument so just let
+# configure find it automatically
+ifeq ($(BR2_PACKAGE_MPFR),y)
+GAWK_DEPENDENCIES += mpfr
+else
+GAWK_CONF_OPTS += --without-mpfr
+endif
+
 # We don't have a host-busybox, and we don't want to use readline or mpfr
 HOST_GAWK_DEPENDENCIES =