projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
a21566d
)
package/fbv: Fix static linking against libpng
author
Bernd Kuhls
<bernd.kuhls@t-online.de>
Sun, 10 Aug 2014 15:12:08 +0000
(17:12 +0200)
committer
Peter Korsgaard
<peter@korsgaard.com>
Mon, 11 Aug 2014 21:30:25 +0000
(23:30 +0200)
Fixes
http://autobuild.buildroot.net/results/9ca/
9cacec257f979745a7d4a43224b243ee4e16f9ac
/
http://autobuild.buildroot.net/results/996/
996e42396546555e9fcf0c7135aac610ccca4eee
/
http://autobuild.buildroot.net/results/c91/
c918046900045c34c73e16578026cce3e6bcccf8
/
[Peter: adjust description, pass --static to pkg-config, only use for static linking]
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/fbv/fbv.mk
patch
|
blob
|
history
diff --git
a/package/fbv/fbv.mk
b/package/fbv/fbv.mk
index 6f41d9ff80512824a3c7ae0b6938d37e7cd07bac..cc1dc7be8816da1fff92946087102f32be4adfd2 100644
(file)
--- a/
package/fbv/fbv.mk
+++ b/
package/fbv/fbv.mk
@@
-15,6
+15,12
@@
FBV_DEPENDENCIES = # empty
FBV_CONFIGURE_OPTS = # empty
ifeq ($(BR2_PACKAGE_FBV_PNG),y)
FBV_DEPENDENCIES += libpng
+
+# libpng in turn depends on other libraries
+ifeq ($(BR2_PREFER_STATIC_LIB),y)
+FBV_CONFIGURE_OPTS += "--libs=$(shell $(PKGg_CONFIG_HOST_BINARY) --libs libpng --static)"
+endif
+
else
FBV_CONFIGURE_OPTS += --without-libpng
endif