package/dhcp: install shared libraries
authorCarlos Santos <unixmania@gmail.com>
Fri, 9 Aug 2019 02:27:59 +0000 (23:27 -0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 9 Aug 2019 20:43:12 +0000 (22:43 +0200)
We don't use "make install" for target installation because we build all
utilities (server, relay, client) but install only the selected ones.

The utilities, however, require the shared libraries to work, so use the
"install-exec" make target to install them. This also installs static
libraries but they are removed later by target-finalize.

With this change the omshell utility is installed if server is selected.
We keep it, since it is small and may be useful at run-time.

Fixes:
  https://bugs.busybox.net/show_bug.cgi?id=12086

Signed-off-by: Carlos Santos <unixmania@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/dhcp/dhcp.mk

index 86f5c69a77f114a52855052e9926d4913123363d..5f56c864146b0355ae4dac33540b65a82df4629f 100644 (file)
@@ -40,7 +40,15 @@ ifeq ($(BR2_PACKAGE_DHCP_SERVER_DELAYED_ACK),y)
 DHCP_CONF_OPTS += --enable-delayed-ack
 endif
 
+define DHCP_INSTALL_LIBS
+       $(MAKE) -C $(@D)/common install-exec DESTDIR=$(TARGET_DIR)
+       $(MAKE) -C $(@D)/omapip install-exec DESTDIR=$(TARGET_DIR)
+endef
+
 ifeq ($(BR2_PACKAGE_DHCP_SERVER),y)
+define DHCP_INSTALL_CTL_LIBS
+       $(MAKE) -C $(@D)/dhcpctl install-exec DESTDIR=$(TARGET_DIR)
+endef
 define DHCP_INSTALL_SERVER
        mkdir -p $(TARGET_DIR)/var/lib
        (cd $(TARGET_DIR)/var/lib; ln -snf /tmp dhcp)
@@ -99,6 +107,8 @@ endef
 endif
 
 define DHCP_INSTALL_TARGET_CMDS
+       $(DHCP_INSTALL_LIBS)
+       $(DHCP_INSTALL_CTL_LIBS)
        $(DHCP_INSTALL_RELAY)
        $(DHCP_INSTALL_SERVER)
        $(DHCP_INSTALL_CLIENT)