package/pure-ftpd: add optional support for libsodium
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 21 Feb 2016 17:34:56 +0000 (18:34 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 21 Feb 2016 20:28:32 +0000 (21:28 +0100)
When libsodium was compiled before, pure-ftpd will use it as optional
dependency:

$ output/host/usr/bin/x86_64-linux-readelf -a output/target/usr/bin/pure-statsdecode | grep NEEDED
 0x0000000000000001 (NEEDED)             Shared library: [libsodium.so.17]
 0x0000000000000001 (NEEDED)             Shared library: [libcrypt.so.1]
 0x0000000000000001 (NEEDED)             Shared library: [libc.so.1]

The build system offers no option to en-/disable libsodium support,
check configure.ac, line 953.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pure-ftpd/pure-ftpd.mk

index 8df4c232cb3b539c6d2d74103d695504fae4d2ec..e1040fa15959843b0240aa9dd5dc6801a4180f08 100644 (file)
@@ -27,6 +27,10 @@ else
 PURE_FTPD_CONF_OPTS += --without-capabilities
 endif
 
+ifeq ($(BR2_PACKAGE_LIBSODIUM),y)
+PURE_FTPD_DEPENDENCIES += libsodium
+endif
+
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 PURE_FTPD_CONF_OPTS += --with-tls
 PURE_FTPD_DEPENDENCIES += openssl