sconeserver: use direct imagemagick disable
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 15 Oct 2015 12:48:50 +0000 (09:48 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 15 Oct 2015 20:23:07 +0000 (22:23 +0200)
Disabling sconesite image isn't enough to avoid imagemagick
autodetection, and if it's present in the host (distro) but not in the
target it gets automatically picked up. Fixes:
http://autobuild.buildroot.net/results/377/37705926f3023395c54af0532ff95f0125fbaa66/

Also add a comment about autoreconf.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/sconeserver/sconeserver.mk

index beca926f7d8eec47f6f0d950aef9c2446dd92687..2072142c2dfcec3a528aff5b79bb4f5101497498 100644 (file)
@@ -10,7 +10,7 @@ SCONESERVER_VERSION = 3b886c3dda6eda39bcb27472d29ed7fd3185ba1d
 SCONESERVER_SITE = $(call github,sconemad,sconeserver,$(SCONESERVER_VERSION))
 SCONESERVER_LICENSE = GPLv2+
 SCONESERVER_LICENSE_FILES = COPYING
-
+# For 0001-fix-ssl-libs-ordering.patch and configure isn't up to date
 SCONESERVER_AUTORECONF = YES
 SCONESERVER_DEPENDENCIES += pcre
 SCONESERVER_CONF_OPTS += --with-ip --with-local --with-ip6
@@ -50,7 +50,7 @@ SCONESERVER_CONF_OPTS += \
        --with-sconesite-image \
        --with-Magick++-config="$(STAGING_DIR)/usr/bin/Magick++-config"
 else
-SCONESERVER_CONF_OPTS += --without-sconesite-image
+SCONESERVER_CONF_OPTS += --without-sconesite-image --with-Magick++-config=no
 endif
 
 ifeq ($(BR2_PACKAGE_SCONESERVER_MYSQL),y)