package/qemu: enable or1k support in host-qemu
authorRomain Naour <romain.naour@gmail.com>
Fri, 17 Apr 2020 20:16:26 +0000 (22:16 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 17 Apr 2020 20:54:38 +0000 (22:54 +0200)
This change enables host qemu support for or1k which among other
things allows to test this architecture in gitlab.

The or1k support was named or32 until Qemu 2.9.0 and then renamed or1k
in upstream commit [1]. Since we're already using Qemu 4.2.0, we use
the or1k name.

Tested using qemu_or1k_defconfig.

[1] https://git.qemu.org/?p=qemu.git;a=commit;h=4a09d0bb34ab030e09e87173b2e3ec0fd7616cff

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/qemu/Config.in.host
package/qemu/qemu.mk

index ea9281c5fb5493b146139c4c33ce6d4b42aa3816..5ed160159aee59c9daca412dd987b70c84644bd6 100644 (file)
@@ -11,6 +11,7 @@ config BR2_PACKAGE_HOST_QEMU_ARCH_SUPPORTS
        default y if BR2_mips
        default y if BR2_mipsel
        default y if BR2_nios2
+       default y if BR2_or1k
        default y if BR2_powerpc
        default y if BR2_powerpc64
        default y if BR2_powerpc64le
index 712491a208fd4f521474f3c867283194daebeba6..e8b43d3b366fbad355e315b030f76cc5af5e46ea 100644 (file)
@@ -199,6 +199,7 @@ HOST_QEMU_DEPENDENCIES = host-pkgconf host-zlib host-libglib2 host-pixman host-p
 #       mips64          mips64
 #       mips64el        mips64el
 #       nios2           nios2
+#       or1k            or1k
 #       powerpc         ppc
 #       powerpc64       ppc64
 #       powerpc64le     ppc64 (system) / ppc64le (usermode)