package/mesa3d: remove -mno-compact-eh for Code Sourcery MIPS
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 29 Sep 2019 06:47:24 +0000 (08:47 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 29 Sep 2019 07:12:42 +0000 (09:12 +0200)
https://git.buildroot.net/buildroot/commit/package/mesa3d?id=e032a29604e843c8adc551d5ceb3c45bc7715b4d
added -mno-compact-eh to CFLAGS/CXXFLAGS.

This breaks mesa build since its switch to meson:

Sanity check compile stderr:
cc: error: unrecognized command line option ‘-mno-compact-eh’; did you mean ‘-fno-compare-elim’?

It turns out that mesa3d still builds now with this option.

Fixes:
http://autobuild.buildroot.net/results/37f/37fce69751aa31ae467d502e660d7db513333d4d/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/mesa3d/mesa3d.mk

index b47c6b9b2e7b2806340d7efb280e287588c1b761..35fe2bdbe56d7dbc5d4bb972c87acef36b401ea4 100644 (file)
@@ -54,14 +54,6 @@ ifeq ($(BR2_PACKAGE_MESA3D_NEEDS_ELFUTILS),y)
 MESA3D_DEPENDENCIES += elfutils
 endif
 
-# The Sourcery MIPS toolchain has a special (non-upstream) feature to
-# have "compact exception handling", which unfortunately breaks with
-# mesa3d, so we disable it here by passing -mno-compact-eh.
-ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS),y)
-MESA3D_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -mno-compact-eh"
-MESA3D_CONF_ENV += CXXFLAGS="$(TARGET_CXXFLAGS) -mno-compact-eh"
-endif
-
 ifeq ($(BR2_PACKAGE_MESA3D_OPENGL_GLX),y)
 # Disable-mangling not yet supported by meson build system.
 # glx: