package/vlc: add optional dependency to libdvdnav
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 12 Aug 2018 20:29:24 +0000 (22:29 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 16 Aug 2018 10:01:19 +0000 (12:01 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/vlc/vlc.mk

index 928b3fabb8d38f8e0463a0b6c6b6393d91c2e059..9a8ee56256ef88305447fb619529de5a570e67fc 100644 (file)
@@ -39,7 +39,6 @@ VLC_CONF_OPTS += \
        --disable-caca \
        --disable-chromaprint \
        --disable-dca \
-       --disable-dvdnav \
        --disable-fluidsynth \
        --disable-gles1 \
        --disable-goom \
@@ -206,6 +205,13 @@ else
 VLC_CONF_OPTS += --disable-dvbpsi
 endif
 
+ifeq ($(BR2_PACKAGE_LIBDVDNAV),y)
+VLC_CONF_OPTS += --enable-dvdnav
+VLC_DEPENDENCIES += libdvdnav
+else
+VLC_CONF_OPTS += --disable-dvdnav
+endif
+
 ifeq ($(BR2_PACKAGE_LIBDVDREAD),y)
 VLC_CONF_OPTS += --enable-dvdread
 VLC_DEPENDENCIES += libdvdread