mpv: fix wayland deps
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 28 Apr 2016 11:20:45 +0000 (08:20 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 28 Apr 2016 11:34:39 +0000 (13:34 +0200)
The wayland backend requires libxkbcommon, so when wayland is available
select it to avoid build failure and obscure dependencies. Fixes:
http://autobuild.buildroot.net/results/ed2/ed2660361c9720e48dd5959f2711fd7f14031b0d/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mpv/Config.in
package/mpv/mpv.mk

index 0f5aa970f205fb863eadfe7baec9b7bce55353b8..36617e56f91c54f6a8e82d3d40ad1bb611d2f4ff 100644 (file)
@@ -6,6 +6,8 @@ config BR2_PACKAGE_MPV
        select BR2_PACKAGE_FFMPEG
        select BR2_PACKAGE_FFMPEG_SWSCALE
        select BR2_PACKAGE_ZLIB
+       # Select xkbcommon for wayland to avoid being misterious
+       select BR2_PACKAGE_LIBXKBCOMMON if BR2_PACKAGE_WAYLAND
        help
          mpv is a fork of mplayer2 and MPlayer. It shares some features
          with the former projects while introducing many more.
index 0032eb58574453091c742b68d4bf75e4b5cc32f1..605e8912ffe328424107d62337641e32d2c1c0a7 100644 (file)
@@ -187,7 +187,7 @@ endif
 # wayland support
 ifeq ($(BR2_PACKAGE_WAYLAND),y)
 MPV_CONF_OPTS += --enable-wayland
-MPV_DEPENDENCIES += wayland
+MPV_DEPENDENCIES += libxkbcommon wayland
 else
 MPV_CONF_OPTS += --disable-wayland
 endif