package/openzwave: set back -fPIC
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Mon, 2 Aug 2021 20:44:00 +0000 (22:44 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 3 Aug 2021 21:13:37 +0000 (23:13 +0200)
Set back -fPIC in CFLAGS which was wrongly removed as a side effect of
commit c5ca521e232eae31276e7a12d17f0cf9d9c0108f.

Another side-effect of that commit was to remove
-DSYSCONFDIR="\"$(PREFIX)/etc/openzwave/\"" - however, we don't need
SYSCONFDIR to be set, since /etc/openzwave is checked first anyway (see
cpp/src/Options.cpp).

Fixes:
 - http://autobuild.buildroot.org/results/161f53574697016ab8bdb91aaaf4a2be5410ebb0

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/openzwave/openzwave.mk

index 9c28c0a13b4263bb94b6a2f9080c60850e265e07..0f639635dd7455fe58e672b0c34217c1eef50fdd 100644 (file)
@@ -23,7 +23,7 @@ OPENZWAVE_INSTALL_STAGING = YES
 # the correct directory otherwise openzwave will install configuration files in
 # $(PREFIX)/etc/openzwave.
 # Disable doxygen documentation.
-# Set {DEBUG,RELEASE}_CFLAGS to an empty value to remove -Werror.
+# Set {DEBUG,RELEASE}_CFLAGS to remove -Werror.
 OPENZWAVE_MAKE_OPTS = \
        CROSS_COMPILE="$(TARGET_CROSS)" \
        PREFIX=/usr \
@@ -31,8 +31,8 @@ OPENZWAVE_MAKE_OPTS = \
        pkgconfigdir=/usr/lib/pkgconfig \
        sysconfdir=/etc/openzwave \
        DOXYGEN= \
-       DEBUG_CFLAGS= \
-       RELEASE_CFLAGS= \
+       DEBUG_CFLAGS="-fPIC" \
+       RELEASE_CFLAGS="-fPIC" \
        USE_BI_TXML=0
 
 ifeq ($(BR2_PACKAGE_HAS_UDEV),y)