Revert "core: also display the custom help with our main help"
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 16 Apr 2016 21:20:17 +0000 (23:20 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 17 Apr 2016 08:55:23 +0000 (10:55 +0200)
This reverts commit 0a767deba004c920e7824543380cffbb298507f8.

Turns out that the custom help is not available when the $(O) directory
has not been configure yet (i.e. when there is no .config already
filled).

Rather than trying to work around this limitation with dirty hacks, just
revert this feature. After all, this will not prevent an external.mk
from providing custom help anyway; it's just not gonna be advertised nor
displayed with the main help.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: Peter Korsgaard <peter@korsgaard.com>
Cc: Jérôme Pouiller <jezz@sysmic.org>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Makefile

index 55735ea735ae182bee75c9e69accb365252477a1..d205ac9eb3da5476efd6fc57b9e398a38e8f2c4e 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -895,9 +895,7 @@ endif
        rm -rf $(BR2_CONFIG) $(CONFIG_DIR)/.config.old $(CONFIG_DIR)/..config.tmp \
                $(CONFIG_DIR)/.auto.deps $(BR2_EXTERNAL_FILE)
 
-help: help-internal help-custom
-
-help-internal:
+help:
        @echo 'Cleaning:'
        @echo '  clean                  - delete all files created by build'
        @echo '  distclean              - delete all non-source files (including .config)'
@@ -970,6 +968,7 @@ endif
        @echo '  source-check           - check selected packages for valid download URLs'
        @echo '  external-deps          - list external packages used'
        @echo '  legal-info             - generate info about license compliance'
+       @echo '  help-custom            - print help about custom actions (if any)'
        @echo
        @echo '  make V=0|1             - 0 => quiet build (default), 1 => verbose build'
        @echo '  make O=dir             - Locate all output files in "dir", including .config'