gcc: host-cloog is not needed for graphite support on gcc 5.x
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 7 Dec 2015 07:31:31 +0000 (08:31 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 7 Dec 2015 07:34:17 +0000 (08:34 +0100)
See https://gcc.gnu.org/gcc-5/changes.html

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gcc/gcc.mk

index b9551e89747fcfd430e4f5cee37ec15c64297e11..07883d074a6ef6b630b97522c33636f81547b994 100644 (file)
@@ -170,8 +170,14 @@ HOST_GCC_COMMON_CONF_OPTS += --with-mpc=$(HOST_DIR)/usr
 endif
 
 ifeq ($(BR2_GCC_ENABLE_GRAPHITE),y)
-HOST_GCC_COMMON_DEPENDENCIES += host-isl host-cloog
-HOST_GCC_COMMON_CONF_OPTS += --with-isl=$(HOST_DIR)/usr --with-cloog=$(HOST_DIR)/usr
+HOST_GCC_COMMON_DEPENDENCIES += host-isl
+HOST_GCC_COMMON_CONF_OPTS += --with-isl=$(HOST_DIR)/usr
+# gcc 5 doesn't need cloog any more, see
+# https://gcc.gnu.org/gcc-5/changes.html
+ifeq ($(BR2_TOOLCHAIN_GCC_AT_LEAST_5),)
+HOST_GCC_COMMON_DEPENDENCIES += host-cloog
+HOST_GCC_COMMON_CONF_OPTS += --with-cloog=$(HOST_DIR)/usr
+endif
 else
 HOST_GCC_COMMON_CONF_OPTS += --without-isl --without-cloog
 endif