gptfdisk: fix installation step
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 7 Mar 2013 10:45:27 +0000 (10:45 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 10 Mar 2013 21:22:55 +0000 (22:22 +0100)
The installation step was not giving the full destination path even
though it was using -D, and it was forgetting to explicitly specify
the permissions of the file to install. This commit fixes both of
these minor issues.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/gptfdisk/gptfdisk.mk

index 656a18761de1e5287b73306415b2d2f37daacae6..988eecf0845125d1c2bc6b7e8ba05bc9c9708169 100644 (file)
@@ -22,7 +22,7 @@ endef
 
 define GPTFDISK_INSTALL_TARGET_CMDS
        for i in $(GPTFDISK_TARGETS_y); do \
-           $(INSTALL) -D $(@D)/$$i $(TARGET_DIR)/usr/sbin/; \
+           $(INSTALL) -D -m 0755 $(@D)/$$i $(TARGET_DIR)/usr/sbin/$$i; \
        done
 endef