make certain the target directory exists
authorEric Andersen <andersen@codepoet.org>
Wed, 15 Nov 2006 21:00:07 +0000 (21:00 -0000)
committerEric Andersen <andersen@codepoet.org>
Wed, 15 Nov 2006 21:00:07 +0000 (21:00 -0000)
Makefile

index eefa9e5825ace9aeb04c83c931b3e767aab4f806..71d2ded46e06ae6178341eb8d03be84b49dba8cf 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -103,6 +103,7 @@ $(STAGING_DIR):
        @ln -snf ../lib $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/lib
 
 $(TARGET_DIR):
+       mkdir -p $(TARGET_DIR)
        if [ -d "$(TARGET_SKELETON)" ] ; then \
                cp -fa $(TARGET_SKELETON)/* $(TARGET_DIR)/; \
        fi;