package/qt5cinex: convert to qmake infrastructure
authorAndreas Naumann <anaumann@ultratronik.de>
Mon, 17 Feb 2020 21:23:38 +0000 (22:23 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 11 Mar 2020 22:05:53 +0000 (23:05 +0100)
Keep custom install logic because qt5cinex has no built-in install
target.

Signed-off-by: Andreas Naumann <anaumann@ultratronik.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/qt5cinex/qt5cinex.mk

index 89c38ee3f586019330710ccc96186f07b5f40ea7..70038028d9bc2baf7a22e1294dcbb0a657625e90 100644 (file)
@@ -12,19 +12,11 @@ QT5CINEX_HD = rpi_
 endif
 
 QT5CINEX_SOURCE = Qt5_CinematicExperience_$(QT5CINEX_HD)$(QT5CINEX_VERSION).tgz
-QT5CINEX_DEPENDENCIES = qt5base qt5declarative
+QT5CINEX_DEPENDENCIES = qt5declarative
 
 QT5CINEX_LICENSE = CC-BY-3.0
 QT5CINEX_LICENSE_FILES = README
 
-define QT5CINEX_CONFIGURE_CMDS
-       cd $(@D); $(TARGET_MAKE_ENV) $(HOST_DIR)/bin/qmake
-endef
-
-define QT5CINEX_BUILD_CMDS
-       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)
-endef
-
 # In addition to the Cinematic Experience itself, we also install a
 # wrapper shell script to /usr/bin: the Cinematic Experience binary
 # wants its resource files to be available directly under a contents/
@@ -39,4 +31,4 @@ define QT5CINEX_INSTALL_TARGET_CMDS
                $(TARGET_DIR)/usr/bin/CinematicExperience-demo
 endef
 
-$(eval $(generic-package))
+$(eval $(qmake-package))