libmicrohttpd: Fix cross compilation broken since 0.9.35
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 4 May 2014 09:04:40 +0000 (11:04 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 4 May 2014 19:10:27 +0000 (21:10 +0200)
Fixes http://autobuild.buildroot.net/results/cb2/cb2cec1295a40667a3c21060864dd0e65a312c3e

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libmicrohttpd/libmicrohttpd-0001-cross.patch [new file with mode: 0644]
package/libmicrohttpd/libmicrohttpd.mk

diff --git a/package/libmicrohttpd/libmicrohttpd-0001-cross.patch b/package/libmicrohttpd/libmicrohttpd-0001-cross.patch
new file mode 100644 (file)
index 0000000..5980b9c
--- /dev/null
@@ -0,0 +1,28 @@
+Fix cross-compilation
+
+Patch sent upstream: http://article.gmane.org/gmane.comp.gnu.libmicrohttpd/1193
+
+Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
+
+diff -uNr libmicrohttpd-0.9.35.org/configure.ac libmicrohttpd-0.9.35/configure.ac
+--- libmicrohttpd-0.9.35.org/configure.ac      2014-05-02 20:38:40.000000000 +0200
++++ libmicrohttpd-0.9.35/configure.ac  2014-05-04 09:17:00.000000000 +0200
+@@ -639,8 +639,7 @@
+         SAVE_CPPFLAGS="$CPPFLAGS"
+         LDFLAGS="-L$with_gnutls/lib $LDFLAGS"
+         CPPFLAGS="-I$with_gnutls/include $CPPFLAGS"
+-        AC_CHECK_FILE([$with_gnutls/include/gnutls/gnutls.h],
+-          [AC_CHECK_HEADERS([gnutls/gnutls.h],
++          AC_CHECK_HEADERS([gnutls/gnutls.h],
+             [AC_CHECK_LIB([gnutls], [gnutls_priority_set],
+               [
+                 GNUTLS_CPPFLAGS="-I$with_gnutls/include"
+@@ -648,7 +647,7 @@
+                 GNUTLS_LIBS="-lgnutls"
+                 AC_CHECK_LIB([gnutls], [gnutls_load_file], [AC_CHECK_LIB([gnutls], [gnutls_privkey_import_x509_raw], [have_gnutls_sni=yes])])
+                 have_gnutls=yes
+-              ])])])
++              ])])
+         AS_IF([test "x$have_gnutls" != "xyes"], [AC_MSG_ERROR([can't find usable libgnutls at specified prefix $with_gnutls])])
+         LDFLAGS="$SAVE_LDFLAGS"
+         CPPFLAGS="$SAVE_CPPFLAGS"
index a4cc5dbc5f79b538363fd94a33e871ad6ed2adbd..edf4f9a63128477b85b92409c7c7edce91b1d8d6 100644 (file)
@@ -8,6 +8,7 @@ LIBMICROHTTPD_VERSION = 0.9.35
 LIBMICROHTTPD_SITE = $(BR2_GNU_MIRROR)/libmicrohttpd
 LIBMICROHTTPD_LICENSE_FILES = COPYING
 LIBMICROHTTPD_INSTALL_STAGING = YES
+LIBMICROHTTPD_AUTORECONF = YES
 LIBMICROHTTPD_CONF_OPT = --disable-curl --disable-spdy
 
 ifeq ($(BR2_PACKAGE_LIBMICROHTTPD_SSL),y)