gst1-plugins-ugly: Add option for building x264 plugin
authorVincent Dehors <vincent.dehors@openwide.fr>
Fri, 8 Jan 2016 14:32:19 +0000 (15:32 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 18 Jan 2016 21:48:02 +0000 (22:48 +0100)
As x264 is packaged, we can also build the gstreamer plugin using it.
This commit adds the option in menuconfig and make sure it is built if
selected.

[Peter: split fix, add GPL tag, update help text and commit description]
Signed-off-by: Vincent Dehors <vincent.dehors@openwide.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gstreamer1/gst1-plugins-ugly/Config.in
package/gstreamer1/gst1-plugins-ugly/gst1-plugins-ugly.mk

index f33e2588d9b2818c933901860b9e33c314bd9e01..fbcb128c22e7fd0b85838e63c3ef90726a2aed97 100644 (file)
@@ -67,6 +67,12 @@ config BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_MPEG2DEC
        help
          LibMpeg2 decoder
 
+config BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_X264
+       bool "x264"
+       select BR2_PACKAGE_X264
+       help
+         x264 encoder
+
 # Note: to get descriptions use the following.
 # # find . -name 'plugin-*.xml' | xargs grep -m 1 description
 endif
index 08315397b79545120f8f2ca4bb8f9bd937220e90..64e7e92343e04ecd31f7a1aad05387a3f0545b66 100644 (file)
@@ -19,8 +19,7 @@ GST1_PLUGINS_UGLY_CONF_OPTS += \
        --disable-amrwb \
        --disable-cdio \
        --disable-sidplay \
-       --disable-twolame \
-       --disable-x264
+       --disable-twolame
 
 GST1_PLUGINS_UGLY_DEPENDENCIES = gstreamer1 gst1-plugins-base
 
@@ -90,6 +89,14 @@ else
 GST1_PLUGINS_UGLY_CONF_OPTS += --disable-mpeg2dec
 endif
 
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_UGLY_PLUGIN_X264),y)
+GST1_PLUGINS_UGLY_CONF_OPTS += --enable-x264
+GST1_PLUGINS_UGLY_DEPENDENCIES += x264
+GST1_PLUGINS_UGLY_HAS_GPL_LICENSE = y
+else
+GST1_PLUGINS_UGLY_CONF_OPTS += --disable-x264
+endif
+
 # Add GPL license if GPL plugins enabled.
 ifeq ($(GST1_PLUGINS_UGLY_HAS_GPL_LICENSE),y)
 GST1_PLUGINS_UGLY_LICENSE += GPLv2