package/boost: use BR2_ENABLE_RUNTIME_DEBUG iso BR2_ENABLE_DEBUG
authorThomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Tue, 1 Jun 2021 14:34:12 +0000 (16:34 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Tue, 1 Jun 2021 20:39:37 +0000 (22:39 +0200)
BR2_ENABLE_DEBUG should just steer the availability of debug symbols and
should have no negative effect on performance.

Introduction of 'assert' statements, 'debug'-type builds with additional
logging, etc. should be steered by BR2_ENABLE_RUNTIME_DEBUG instead.

Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/boost/boost.mk

index 8d745ecc72ee4c8071273b3a0f5b8a2a62afeb76..e72ddf897c8ba599215841606f48d19d21b37ddd 100644 (file)
@@ -95,7 +95,7 @@ BOOST_OPTS += --no-cmake-config \
             toolset=gcc \
             threading=multi \
             abi=$(BOOST_ABI) \
-            variant=$(if $(BR2_ENABLE_DEBUG),debug,release)
+            variant=$(if $(BR2_ENABLE_RUNTIME_DEBUG),debug,release)
 
 ifeq ($(BR2_sparc64),y)
 BOOST_OPTS += architecture=sparc instruction-set=ultrasparc