a10disp: new package
authorSpenser Gilliland <spenser@gillilanding.com>
Fri, 19 Jul 2013 23:37:51 +0000 (18:37 -0500)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 28 Jul 2013 14:42:48 +0000 (16:42 +0200)
Signed-off-by: Spenser Gilliland <spenser@gillilanding.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/a10disp/Config.in [new file with mode: 0644]
package/a10disp/a10disp.mk [new file with mode: 0644]

index 9e1c0aee57c55e6db38cd8e0d6a585144a6491f3..155119ffa07ac3252cef104da3ddacd2759e6ff6 100644 (file)
@@ -230,6 +230,7 @@ source "package/ux500-firmware/Config.in"
 source "package/zd1211-firmware/Config.in"
 endmenu
 source "package/freescale-imx/Config.in"
+source "package/a10disp/Config.in"
 source "package/acpid/Config.in"
 source "package/cdrkit/Config.in"
 source "package/dbus/Config.in"
diff --git a/package/a10disp/Config.in b/package/a10disp/Config.in
new file mode 100644 (file)
index 0000000..b4edf31
--- /dev/null
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_A10DISP
+       bool "a10disp"
+       depends on BR2_arm
+       depends on BR2_LINUX_KERNEL
+       help
+         Program to change the display mode of Allwinner ARM SOCs running
+         the linux-sunxi kernel (and not the mainline kernel.)
+
+         http://github.com/hglm/a10disp
+
+comment "a10disp requires the linux kernel"
+       depends on BR2_arm && !BR2_LINUX_KERNEL
diff --git a/package/a10disp/a10disp.mk b/package/a10disp/a10disp.mk
new file mode 100644 (file)
index 0000000..fee4ac7
--- /dev/null
@@ -0,0 +1,22 @@
+################################################################################
+#
+# a10disp
+#
+################################################################################
+
+A10DISP_VERSION = a899cc6dcf
+A10DISP_SITE = http://github.com/hglm/a10disp/tarball/$(A10DISP_VERSION)
+A10DISP_LICENSE = MIT
+
+A10DISP_DEPENDENCIES = linux
+
+define A10DISP_BUILD_CMDS
+       cp -f $(LINUX_DIR)/include/video/sunxi_disp_ioctl.h $(@D)/
+       $(TARGET_CC) $(TARGET_CFLAGS) $(@D)/a10disp.c -o $(@D)/a10disp
+endef
+
+define A10DISP_INSTALL_TARGET_CMDS
+       $(INSTALL) -D -m 0755 $(@D)/a10disp $(TARGET_DIR)/usr/bin/a10disp
+endef
+
+$(eval $(generic-package))