libcurl: fix configure with openssl when target == host.
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 10 Mar 2009 21:03:14 +0000 (21:03 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 10 Mar 2009 21:03:14 +0000 (21:03 -0000)
package/libcurl/libcurl.mk

index 6a91bb262353d3077ad353b428a7a4462d300e55..fb04da05ddc24937e40bf2e5a65140b7f327a5e8 100644 (file)
@@ -13,6 +13,11 @@ LIBCURL_CONF_OPT = --disable-verbose --disable-manual --enable-hidden-symbols \
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 LIBCURL_DEPENDENCIES += openssl
 LIBCURL_CONF_ENV += ac_cv_lib_crypto_CRYPTO_lock=yes
+# configure adds the cross openssl dir to LD_LIBRARY_PATH which screws up
+# native stuff during the rest of configure when target == host.
+# Fix it by setting LD_LIBRARY_PATH to something sensible so those libs
+# are found first.
+LIBCURL_CONF_ENV += LD_LIBRARY_PATH=$$LD_LIBRARY_PATH:/lib:/usr/lib
 LIBCURL_CONF_OPT += --with-ssl=$(STAGING_DIR)/usr --with-random=/dev/urandom
 endif