libevas: forcibly disable cpu optimization options if not applicable
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 30 Jan 2012 07:52:52 +0000 (08:52 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 30 Jan 2012 07:52:52 +0000 (08:52 +0100)
Otherwise the configure script will automatically enable them for
potentially compatible targets.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/efl/libevas/libevas.mk

index 3a1e42d2ed3660b60574ae2c8eef719f49407fac..6ad1126e772e4c12c4dfedee95b4d8aadfe5379a 100644 (file)
@@ -103,19 +103,28 @@ LIBEVAS_CONF_OPT += --enable-cpu-sse
 
 ifneq ($(BR2_x86_pentium3)$(BR2_x86_pentium4)$(BR2_x86_prescott)$(BR2_x86_athlon_4)$(BR2_x86_opteron)$(BR2_x86_c32)$(BR2_x86_64_opteron),y)
 LIBEVAS_CONF_OPT += --enable-cpu-sse3
-
+else
+LIBEVAS_CONF_OPT += --disable-cpu-sse3
 endif # sse3
+else
+LIBEVAS_CONF_OPT += --disable-cpu-sse
 endif # sse
+else
+LIBEVAS_CONF_OPT += --disable-cpu-mmx
 endif # mmx
 endif # x86
 
 ifeq ($(BR2_powerpc_7400)$(BR2_powerpc_7450)$(BR2_powerpc_970),y)
 LIBEVAS_CONF_OPT += --enable-cpu-altivec
+else
+LIBEVAS_CONF_OPT += --disable-cpu-altivec
 endif
 
 ifeq ($(BR2_cortex_a8)$(BR2_cortex_a9),y)
 # NEON is optional for A9
 LIBEVAS_CONF_OPT += --enable-cpu-neon
+else
+LIBEVAS_CONF_OPT += --disable-cpu-neon
 endif
 
 # loaders