luarocks: bump to version 3.0.1
authorFrancois Perrad <fperrad@gmail.com>
Thu, 16 Aug 2018 07:30:49 +0000 (09:30 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 16 Aug 2018 09:58:08 +0000 (11:58 +0200)
The meaning of --sysconfdir has changed (see announcement
http://lua-users.org/lists/lua-l/2018-08/msg00101.html), So,
LUAROCKS_CONFIG_DIR & LUAROCKS_CONFIG_FILE are adjusted.

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/luarocks/0001-allow-libluajit-detection.patch
package/luarocks/luarocks.hash
package/luarocks/luarocks.mk

index c5e52f428194ec93fa48b8fad67c253f7a26d4d0..05d025bba2a4f5e91be400bcb412dd4fe1df5847 100644 (file)
@@ -6,6 +6,8 @@ Subject: [PATCH] allow libluajit detection
 This detection was done only if luarocks is runned by luajit.
 But on Buildroot, luarocks is always runned by lua.
 
+See https://github.com/luarocks/luarocks/pull/883
+
 Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
 ---
  src/luarocks/deps.lua | 4 +---
@@ -15,7 +17,7 @@ diff --git a/src/luarocks/deps.lua b/src/luarocks/deps.lua
 index 8403f12..c1c0220 100644
 --- a/src/luarocks/deps.lua
 +++ b/src/luarocks/deps.lua
-@@ -511,10 +511,8 @@ function deps.check_lua(vars)
+@@ -513,10 +513,8 @@ function deps.check_lua(vars)
        "lua-" .. cfg.lua_version,
        "lua-" .. shortv,
        "lua",
index 87ef6827c6788fff2a1009e71d0e3f32bedfe569..4aa791cb4d70bf581c88a3fb94f8368a78742380 100644 (file)
@@ -1,2 +1,2 @@
 # Locally calculated
-sha256 a43fffb997100f11cccb529a3db5456ce8dab18171a5cb3645f948147b6f64a1  luarocks-3.0.0.tar.gz
+sha256 b989c4b60d6c9edcd65169e5e42fcffbd39cdbebe6b138fa5aea45102f8d9ec0  luarocks-3.0.1.tar.gz
index cd4be266cfa25a62b870c2417051c35f5f5474f1..25e3ad3e22ede9fc0ec3012503cf8dc00188240c 100644 (file)
@@ -4,15 +4,15 @@
 #
 ################################################################################
 
-LUAROCKS_VERSION = 3.0.0
+LUAROCKS_VERSION = 3.0.1
 LUAROCKS_SITE = http://luarocks.org/releases
 LUAROCKS_LICENSE = MIT
 LUAROCKS_LICENSE_FILES = COPYING
 
 HOST_LUAROCKS_DEPENDENCIES = host-luainterpreter
 
-LUAROCKS_CONFIG_DIR = $(HOST_DIR)/etc/luarocks
-LUAROCKS_CONFIG_FILE = $(LUAROCKS_CONFIG_DIR)/config-$(LUAINTERPRETER_ABIVER).lua
+LUAROCKS_CONFIG_DIR = $(HOST_DIR)/etc
+LUAROCKS_CONFIG_FILE = $(LUAROCKS_CONFIG_DIR)/luarocks/config-$(LUAINTERPRETER_ABIVER).lua
 LUAROCKS_CFLAGS = $(TARGET_CFLAGS) -fPIC
 ifeq ($(BR2_PACKAGE_LUA_5_3),y)
 LUAROCKS_CFLAGS += -DLUA_COMPAT_5_2