sngrep: fix error if gnutls and openssl are both enabled
authorAdam Duskett <Aduskett@gmail.com>
Thu, 26 Jan 2017 21:39:31 +0000 (16:39 -0500)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 27 Jan 2017 07:21:19 +0000 (20:21 +1300)
gnutls and openssl support can't be enabled at the same time in
sngrep. Prefer openssl if available, otherwise use gnutls.

Fixes:

  http://autobuild.buildroot.net/results/7c775b1faf7be90fb4acd3653600f7b6b48aa86f/

Signed-off-by: Adam Duskett <aduskett@codeblue.com>
[Thomas:
 - regroup CONF_OPTS lines
 - add an 'else' clause to explicitly disable gnutls and openssl when
   none are available
 - add a reference to the autobuilder failure]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/sngrep/sngrep.mk

index f504771fe59008ce2a420c5aba3512322dd9b109..b4b91c9af51b01f1e8862a967194ceb5b42677a0 100644 (file)
@@ -14,18 +14,15 @@ SNGREP_DEPENDENCIES = libpcap ncurses
 # our ncurses wchar support is not properly detected
 SNGREP_CONF_OPTS += --disable-unicode
 
-ifeq ($(BR2_PACKAGE_GNUTLS),y)
-SNGREP_DEPENDENCIES += gnutls
-SNGREP_CONF_OPTS += --with-gnutls
-else
-SNGREP_CONF_OPTS += --without-gnutls
-endif
-
+# openssl and gnutls can't be enabled at the same time.
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 SNGREP_DEPENDENCIES += openssl
-SNGREP_CONF_OPTS += --with-openssl
+SNGREP_CONF_OPTS += --with-openssl --without-gnutls
+else ifeq ($(BR2_PACKAGE_GNUTLS),y)
+SNGREP_DEPENDENCIES += gnutls
+SNGREP_CONF_OPTS += --with-gnutls --without-openssl
 else
-SNGREP_CONF_OPTS += --without-openssl
+SNGREP_CONF_OPTS += --without-gnutls --without-openssl
 endif
 
 ifeq ($(BR2_PACKAGE_PCRE),y)