package/squeezelite: add optional lirc-tools dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 6 Apr 2019 16:57:58 +0000 (18:57 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 11 Apr 2019 17:36:42 +0000 (19:36 +0200)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/squeezelite/Config.in
package/squeezelite/squeezelite.mk

index 57f55ffc8c10e50b99e18223b7064bb8279b0641..b1820a146dcd2b2bf9b85a6ca10f744a430e7f5e 100644 (file)
@@ -27,6 +27,14 @@ config BR2_PACKAGE_SQUEEZELITE_FFMPEG
 config BR2_PACKAGE_SQUEEZELITE_DSD
        bool "Enable DSD decoding"
 
+config BR2_PACKAGE_SQUEEZELITE_LIRC
+       bool "Enable lirc support"
+       depends on BR2_INSTALL_LIBSTDCPP
+       select BR2_PACKAGE_LIRC_TOOLS
+
+comment "lirc support needs a toolchain with C++"
+       depends on !BR2_INSTALL_LIBSTDCPP
+
 config BR2_PACKAGE_SQUEEZELITE_RESAMPLE
        bool "Enable resampling support"
        select BR2_PACKAGE_LIBSOXR
index 012b5304ab79d395302000d3e78773892c30013e..e41053663a20020c0b2de2f3a8bb6865f2534113 100644 (file)
@@ -20,6 +20,11 @@ ifeq ($(BR2_PACKAGE_SQUEEZELITE_DSD),y)
 SQUEEZELITE_MAKE_OPTS += -DDSD
 endif
 
+ifeq ($(BR2_PACKAGE_SQUEEZELITE_LIRC),y)
+SQUEEZELITE_DEPENDENCIES += lirc-tools
+SQUEEZELITE_MAKE_OPTS += -DIR
+endif
+
 ifeq ($(BR2_PACKAGE_SQUEEZELITE_RESAMPLE),y)
 SQUEEZELITE_DEPENDENCIES += libsoxr
 SQUEEZELITE_MAKE_OPTS += -DRESAMPLE