package/pkg-python: <pkg>_SUBDIR cleanup
authorLionel Orry <lionel.orry@gmail.com>
Thu, 11 Oct 2018 09:57:54 +0000 (11:57 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 6 Feb 2019 16:21:29 +0000 (17:21 +0100)
No functional change is brought by this modification.

This patch:
* removes redundant <pkg>_SRCDIR and <pkg>_BUILDDIR declarations
  (already defined in pkg-generic.mk)
* documents the usage of <pkg>_SUBDIR in the python-specific section of
  the manual.

Signed-off-by: Lionel Orry <lionel.orry@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
docs/manual/adding-packages-python.txt
package/pkg-python.mk

index 5eb6ba51b11886da6e93e6912dabdd0d19edb51e..15137cfd6d57db6316390925e5c6c747aa495966 100644 (file)
@@ -113,6 +113,12 @@ optionally be defined, depending on the package's needs. Many of them
 are only useful in very specific cases, typical packages will
 therefore only use a few of them, or none.
 
+* +PYTHON_FOO_SUBDIR+ may contain the name of a subdirectory inside the
+  package that contains the main +setup.py+ file. This is useful,
+  if for example, the main +setup.py+ file is not at the root of
+  the tree extracted by the tarball. If +HOST_PYTHON_FOO_SUBDIR+ is not
+  specified, it defaults to +PYTHON_FOO_SUBDIR+.
+
 * +PYTHON_FOO_ENV+, to specify additional environment variables to
   pass to the Python +setup.py+ script (for both the build and install
   steps). Note that the infrastructure is automatically passing
index 8d40a7ca48d079a0c3cbf8bd3a4f96ad0698f0fd..e9069204173cd64f87d8a240bf6f377c6d694c4a 100644 (file)
@@ -105,9 +105,6 @@ HOST_PKG_PYTHON_SETUPTOOLS_INSTALL_OPTS = \
 
 define inner-python-package
 
-$(2)_SRCDIR    = $$($(2)_DIR)/$$($(2)_SUBDIR)
-$(2)_BUILDDIR  = $$($(2)_SRCDIR)
-
 $(2)_ENV         ?=
 $(2)_BUILD_OPTS   ?=
 $(2)_INSTALL_OPTS ?=